DRL not working - Hyundai Forums : Hyundai Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 03-25-2019, 02:54 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Location: Saint John/NB/Canada
Drives 2007 Hyundai Tuscon 4wd 2.7L Also 2012 Sonata Hybrid
Posts: 4
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
shaharis is an unknown quantity at this point
(Thread Starter)
DRL not working

I recently replaced my headlights and now I noticed that the Daytime Running Lights are not working. They may not have been working before replacing the headlights. Any help as to where the DRL module might be or what else could be causing this would be great. It is now Law here that they must be working so I need to solve this or else run the headlights all the time. BTW this is a 2007 Tuscon 4WD 2.7L
shaharis is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 03-25-2019, 03:17 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Location: Saint John/NB/Canada
Drives 2007 Hyundai Tuscon 4wd 2.7L Also 2012 Sonata Hybrid
Posts: 4
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
shaharis is an unknown quantity at this point
(Thread Starter)
As a side note I put one of the old lights, still working, back in and the DRL still don't come on.
shaharis is offline  
post #3 of 10 (permalink) Old 03-25-2019, 04:26 PM
Senior Member
 
AUTOSPARK's Avatar
 
Join Date: Nov 2014
Location: Scotland, UK.
Drives : Nissan NV200 Flies : Rans S6ES
Posts: 11,030
Mentioned: 113 Post(s)
Quoted: 2330 Post(s)
AUTOSPARK is an unknown quantity at this point
Quote:
Originally Posted by shaharis View Post
Any help as to where the DRL module might be or what else could be causing this would be great.
This pic turned up in a wee google search....

Attached Images
File Type: png Forum_Image.png (182.0 KB, 16 views)
AUTOSPARK is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 03-25-2019, 05:03 PM
Senior Member
 
grcauto's Avatar
 
Join Date: Jul 2018
Location: Flint, MI USA
Posts: 4,319
Mentioned: 17 Post(s)
Quoted: 1035 Post(s)
grcauto is an unknown quantity at this point
Quote:
Originally Posted by shaharis View Post
I recently replaced my headlights and now I noticed that the Daytime Running Lights are not working. They may not have been working before replacing the headlights. Any help as to where the DRL module might be or what else could be causing this would be great. It is now Law here that they must be working so I need to solve this or else run the headlights all the time. BTW this is a 2007 Tuscon 4WD 2.7L



Best practices for requesting help:If you haven't done so fill in your vehicle info and profile page. At upper right corner under the search box click on user cp (it's your control panel)
This info will show up to the left under your user name and is very helpful.
BE SURE TO ADD YOUR LOCATION SO WE KNOW WHAT MARKET YOU ARE IN.


  • Be sure you are in the correct forum for your vehicle.
  • Do a search for your problem. A lot of stuff has been asked and answered.
  • Do not double post for the same problem.
  • Give the model year....Engine size...transmission type (auto or standard)
  • Take a single issue at a time. Posting multiple issues at once will get convoluted very quickly
  • VIN number can be very helpful
  • Vehicle history can be good. How many miles. If not bought new, how many have you put on it.
  • Describe the problem best you can. If a noise can you get a sound or video file
  • Tell us what has been done, if anything, thus far. If tests have been performed give actual results not OK or passed. If scanned for codes the actual code(s) not O2 sensor or MAF, Etc.
  • If the vehicle has been to a repair facility it would be nice if you could post a picture of that invoice/bill
  • If your vehicle is under warranty you should have the dealer check it out. If it's a problem they see many times they will generate a safety recall of TSB. This is how they know of the problem.

This information can save a lot of time and get you the answers you need much faster.


Thanks,
Welcome aboard.

Of all the things I ever lost I miss my mind the most.
Hey you're not getting any younger
.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
grcauto is offline  
post #5 of 10 (permalink) Old 03-25-2019, 05:33 PM
Senior Member
 
Join Date: Apr 2010
Location: Southern Ca.
Drive 2009 Azera TG, 2007 Accent MC, 2009 Sonata NF, 2010 Genesis BH,
Posts: 815
Mentioned: 64 Post(s)
Quoted: 183 Post(s)
wongpfh is an unknown quantity at this point
Quote:
Originally Posted by shaharis View Post
I recently replaced my headlights and now I noticed that the Daytime Running Lights are not working. They may not have been working before replacing the headlights. Any help as to where the DRL module might be or what else could be causing this would be great. It is now Law here that they must be working so I need to solve this or else run the headlights all the time. BTW this is a 2007 Tuscon 4WD 2.7L
Check the 15A DRL fuse.
Attached Images
File Type: jpg Fuses & Relays info.jpg (198.7 KB, 4 views)
wongpfh is offline  
post #6 of 10 (permalink) Old 03-25-2019, 10:02 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Location: Saint John/NB/Canada
Drives 2007 Hyundai Tuscon 4wd 2.7L Also 2012 Sonata Hybrid
Posts: 4
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
shaharis is an unknown quantity at this point
(Thread Starter)
Quote:
Originally Posted by wongpfh View Post
Check the 15A DRL fuse.
I checked the fuse it's good, unfortunately.
shaharis is offline  
post #7 of 10 (permalink) Old 03-25-2019, 10:18 PM
Senior Member
 
sbr711's Avatar
 
Join Date: Apr 2010
Location: Hiding from those who might be looking for me
I dont own Hyundai car, I drive everybody else Hyundai during day
Posts: 17,370
Mentioned: 265 Post(s)
Quoted: 2525 Post(s)
sbr711 is an unknown quantity at this point
Close up pics of headlamps ?

<--- Please fill in the 'location' and 'what you drive(year & chassis) and engine size' boxes on your personal profile page.
This information makes it much easier for other members to answer/comment on your posts.
sbr711 is offline  
post #8 of 10 (permalink) Old 03-26-2019, 08:02 AM
Senior Member
 
AUTOSPARK's Avatar
 
Join Date: Nov 2014
Location: Scotland, UK.
Drives : Nissan NV200 Flies : Rans S6ES
Posts: 11,030
Mentioned: 113 Post(s)
Quoted: 2330 Post(s)
AUTOSPARK is an unknown quantity at this point
Quote:
Originally Posted by shaharis View Post
what else could be causing this
No power supply or ground to the DRL module.
No alternator input to the module (does the heated rear window work? That's also alternator controlled).
No output from the DRL module.

Basically what I'm getting at is you need to check the wiring at the DRL module. Perhaps @wongpfh can supply a diagram for you to work with.
AUTOSPARK is offline  
post #9 of 10 (permalink) Old 03-26-2019, 06:44 PM
Senior Member
 
Join Date: Apr 2010
Location: Southern Ca.
Drive 2009 Azera TG, 2007 Accent MC, 2009 Sonata NF, 2010 Genesis BH,
Posts: 815
Mentioned: 64 Post(s)
Quoted: 183 Post(s)
wongpfh is an unknown quantity at this point
Quote:
Originally Posted by AUTOSPARK View Post
No power supply or ground to the DRL module.
No alternator input to the module (does the heated rear window work? That's also alternator controlled).
No output from the DRL module.

Basically what I'm getting at is you need to check the wiring at the DRL module. Perhaps @wongpfh can supply a diagram for you to work with.
Diagrams attached.
Attached Images
File Type: jpg DRL1.jpg (119.0 KB, 6 views)
File Type: jpg DRL2.jpg (138.1 KB, 6 views)
wongpfh is offline  
post #10 of 10 (permalink) Old 03-29-2019, 07:33 PM Thread Starter
Junior Member
 
Join Date: Jul 2012
Location: Saint John/NB/Canada
Drives 2007 Hyundai Tuscon 4wd 2.7L Also 2012 Sonata Hybrid
Posts: 4
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
shaharis is an unknown quantity at this point
(Thread Starter)
Quote:
Originally Posted by wongpfh View Post
Diagrams attached.
Thanks, I'll check this weekend.
shaharis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Forums : Hyundai Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome