Hyundai Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter · #1 · (Edited)
Hello...

I have the following problem:

When I pull the wipers lever backwards, washer fluid supply in tank lowers,
but there don`t come liquid out for the jets.
The rear jets don`t spray liquid
The auto sweeping funcion works OK (7 times).

The only way to spray a little of liquid is pulling the lever many times at once.

I deduct that the fluid is going or evaporating somewhere,
The pump makes the noise that`s working...as always.
Any help? Before I have to star searching if one of the pipes is broken..

Someone told me that ejectors are clogged, but I used a pin to clean them and some liquid spits out.

Thanks.
 

·
Registered
Joined
·
7,163 Posts
If a visual inspection doesn't find the source of the problem, you could always run the pump for a full 30 seconds (make sure you have the fluid full) and start looking for the big leak.;)

If you have squirt in neither front nor rear, the fluid may not be making it out of the tank successfully. Broken/open hose or plugged is most likely.
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #3 ·
If you have squirt in neither front nor rear, the fluid may not be making it out of the tank successfully. Broken/open hose or plugged is most likely.
Open = loose?

Just a small leak near right fender.
A mechanic told me that to check the "hoses / tank / pump circuit " from being clogged,
i have to remove the right wheel, then unscrew the plastic cover inside the fender.

Any diagram???
Thanks.
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #5 ·
clean washer reservoir filter ...

Yes, i couldn`t edit the other post. And the problem is that...
I reached the reservoir, but no idea where filter is ..
Thanks..
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #7 ·
Thanks...

Without removing the wheel, I unscrewed right plastic cover underneath the fender. Then I popped out the pump and cleaned the filter. I took pictures, too.

Advice: When inserting the pump back into the tank, first insert the rubber seal ("T" shaped) into the tank and after that, the pump, for easier installing.

And dontè forget put back 2 screws front, neat the bumper !!
I forgot that and plastic cover touched the wheel and broked... I`ll got a new one.

Thanks again a lot.
 

·
Registered
Joined
·
7,163 Posts
Turned out to be plugged - but with what. Could you identify what had gotten into the filter? With regular windshield juice going in and cap returned to position after fills, shouldn't have been anything in there. Methanol will keep anything from 'growing', too. Very atypical. Most vehicles go the whole lifetime without this kind of issue.
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #10 ·
I´ll set up some pictures to show you what I did.
First, there was a blueish substance in the filter. I only used distilled water..
Got the car one year ago with 27.000 km....(now 51.000), so previous owner could have messed it.



 

·
Registered
Joined
·
265 Posts
Discussion Starter · #11 ·
Sorry for bothering again, but....

The inner lining on wheel space got loose, and the that plastic
broke into pieces. Specially the lowe part (under fog lamp)

Can you tell me the diagram or code to boy this plastic shield?
(For the moment, I repaired it with a vinyl sheet....so it won`t hurt the washer pump/hoses).

Do I have to replace the full lining or just that piece??
Please send me the code.
Thanks.

 

·
Registered
Joined
·
7,163 Posts
I know you get very few nights (even in June) when it's very cold in Santiago, but I'm surprised you use distilled water. It doesn't do very good for removing bugs.

Anyway, the user before you has clearly used the 'blue' washer fluid, and it appears that you are seeing precipitate matter either from really bad fluid, or fluid mixed with water with high mineral content. Now that you have cleared this material from the filter, and providing you continue to use only quality fluid and distilled water (and remember to keep the lid on the filler closed!) you should not see this problem again.
 

·
Registered
Joined
·
7,163 Posts
As for your broken fender liner, that looks like a perfect reason for a trip to the junk yard! I'm sure you'll get it a lot cheaper and faster that way than trying to go through a dealer.
 
1 - 14 of 14 Posts
Top