Hyundai Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello everyone, I'm new to the board I guess I've been lucky so far. I bought the car new in 2016 and have had no issues until now. The car has just over 60,000 miles so of course, the warranty is out now. My question is I have 3 lights on. can someone direct me to the problem?
Car Speedometer Vehicle Motor vehicle Tachometer
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
17,387 Posts
can someone direct me to the problem?
I'm afraid not. You will really need to have the ABS/ESC module scanned to find out what trouble code has been logged. That will give you a much better clue about the cause than the random guesses of folk on an internet forum. You'll probably need to visit a garage to have the module scanned though. Most cheap DIY scan tools are not able to communicate with the ABS module.

If I helped you fix it, why not...

Your support is greatly appreciated
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I'm afraid not. You will really need to have the ABS/ESC module scanned to find out what trouble code has been logged. That will give you a much better clue about the cause than the random guesses of folk on an internet forum. You'll probably need to visit a garage to have the module scanned though. Most cheap DIY scan tools are not able to communicate with the ABS module.

If I helped you fix it, why not...

Your support is greatly appreciated
I was afraid of that. I have a scan tool but I wasn't sure if it could scan this. I guess I'll have to find someone. Thank you.
 

·
Registered
Joined
·
5 Posts
My wife’s 2015 Santa Fe Sport with 57k mi had the same three lights come on yesterday. We took it to the dealer today and they diagnosed a bad speed sensor in the hub. They will replace next week. We had a hub replaced 3 years ago, but that time only the traction control light came on.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
They do but they are usually the same ones that I have. I think you need one of those Snap-On ones that cost about 5000.:ROFLMAO:
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
My wife’s 2015 Santa Fe Sport with 57k mi had the same three lights come on yesterday. We took it to the dealer today and they diagnosed a bad speed sensor in the hub. They will replace next week. We had a hub replaced 3 years ago, but that time only the traction control light came on.


Sent from my iPad using Tapatalk
Do you know which hub?
 

·
Registered
2008 Accent 3 dr 5 sp manual; 2010 Genesis Coupe 2LT track 6 sp manual
Joined
·
8,930 Posts
Autel sells scanners for around $150.
 

·
Registered
Joined
·
5 Posts
My wife’s Santa Fe was repaired today. The diagnosis revealed code C1208 which is the LH rear wheel speed sensor. They replaced and charged $220.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #14 ·
Hi everyone here is an update: I was able to get an ABS scanner on it and the code was for the left rear wheel sensor. I replaced such part and all is good again. Thank you all for the help.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
17,387 Posts
I replaced such part and all is good again.
Thanks for taking the time to confirm the fix. Interesting that you and labslave both had the exact same fault :unsure:

If I helped you fix it, why not...

Your support is greatly appreciated
 
1 - 15 of 15 Posts
Top