Hyundai Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
I purchased a Supervision cluster for my 2013 and it looks amazing!! Only problem is it's got approx 30,000 less miles than my car has! I read ilanpro did them in another thread, so I PM'ed him but haven't heard back. Maybe he's not doing that anymore, or maybe he doesn't like me because I'm a n00b. Can anyone point me in the right direction to get the mileage adjusted on this? Thank you very much!!
 

·
Registered
Joined
·
3,637 Posts
I purchased a Supervision cluster for my 2013 and it looks amazing!! Only problem is it's got approx 30,000 less miles than my car has! I read ilanpro did them in another thread, so I PM'ed him but haven't heard back. Maybe he's not doing that anymore, or maybe he doesn't like me because I'm a n00b. Can anyone point me in the right direction to get the mileage adjusted on this? Thank you very much!!
Sent Ilanpro a message, let u know when he answers.
Drew
 

·
Registered
Joined
·
177 Posts
Just pm'ed you I have not been checking lately let me know if you have the brake light on by reprogramming it it can be removed, if you have a turbo cluster on the 2.4l the light will always be on.
 

·
Registered
Joined
·
124 Posts
Discussion Starter #5
Just pm'ed you I have not been checking lately let me know if you have the brake light on by reprogramming it it can be removed, if you have a turbo cluster on the 2.4l the light will always be on.
Hey thanks a lot guys for helping me get in touch with @ilanpro! I put the SV cluster in and have been driving for a couple days with no brake light. I'm pretty sure it is a non-turbo cluster. Everything seems to be 100% functional and NO brake light! Here's the cluster I bought: 14-14 Hyundai Sonata Instrument Cluster Speedometer 11,445 Warranty #22456 | eBay.
@ilanpro I replied to your PM. Thanks again!
 

·
Registered
Joined
·
873 Posts
Hey thanks a lot guys for helping me get in touch with ilanpro I put the SV cluster in and have been driving for a couple days with no brake light. I'm pretty sure it is a non-turbo cluster. Everything seems to be 100% functional and NO brake light! Here's the cluster I bought: 14-14 Hyundai Sonata Instrument Cluster Speedometer 11,445 Warranty #22456 | eBay.
Good to hear, I have been thinking about this upgrade due to the fact that the tpms light actually lights up a portion next to the tire on the SV cluster. On our normal cluster we have to play the guessing game...

Thanks for the link, makes me want to reconsider the swap after I complete my headlight retrofit.
 

·
Registered
Joined
·
124 Posts
Discussion Starter #8
...the tpms light actually lights up a portion next to the tire on the SV cluster. On our normal cluster we have to play the guessing game...
Yeah I noticed today that when I first start the car the cluster does it's initial startup, there's a top view of the car and the 4 tires also light up. I didn't remember seeing them on the original cluster but I thought maybe I wasn't paying attention. I kind of want to let some air out of one of the tires and see what happens now.
 

·
Registered
Joined
·
177 Posts
correct I had a Flat and was able to tell on the cluster the correct tire, I have 2 2.4l sonatas I did the cluster in both one cluster was a turbo the other was a non turbo, all I did is copy the eeprom from the non turbo and flashed the turbo cluster then match the mileage to the car and no more brake light unless the brake is applied. I did save the program in case anyone has the issue I can flash it for you
 

·
Registered
Joined
·
124 Posts
Discussion Starter #15
I had a low tire recently, and the cluster said it was the right rear, but when I checked it it was fine, so I thought it was a TPMS issue. The next day, I noticed the LEFT rear looked a little low. I checked it and sure enough - it was. I added air, and the low tire light on the cluster cleared. Interesting that the warning light was for the opposite tire...
 

·
Registered
Joined
·
394 Posts
I had a low tire recently, and the cluster said it was the right rear, but when I checked it it was fine, so I thought it was a TPMS issue. The next day, I noticed the LEFT rear looked a little low. I checked it and sure enough - it was. I added air, and the low tire light on the cluster cleared. Interesting that the warning light was for the opposite tire...
When you had your tires rotated last time, did the shop do a TPMS re-learn? I have a dumbed down one in my Sonata but I know some that actually show the low tires' location need a relearn.

Sent from my SM-G930P using Tapatalk
 

·
Registered
Joined
·
124 Posts
Discussion Starter #17
When you had your tires rotated last time, did the shop do a TPMS re-learn? I have a dumbed down one in my Sonata but I know some that actually show the low tires' location need a relearn.

Sent from my SM-G930P using Tapatalk
I bought mine CPO and it had new tires. Haven't rotated yet. It's going in this week for two recalls so I'll ask them to check on it.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
177 Posts
I put snow rims and tires on my sonata with Ebay bought TPMS sensors and no relearn needed they should go off. But really do not know. it may just be a bad TPMS stem
 

·
Registered
Joined
·
124 Posts
Discussion Starter #19
1 - 20 of 25 Posts
Top