Hyundai Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1,282 Posts
Funny you should mention this. Not three weeks ago, I had to replace the little bulbs in my seat heater switches that light up the seat icons. I ordered two of each from my local dealer because neither of us could tell from the drawing in his illustrated parts breakdown which bulb was for which function. Total cost to order the four bulbs was around US $24 (your price may vary). I don't know if the same part numbers are used in the rear defroster switch.

The bulbs for the seat icons:
Part # 18691-08041 (black base)

The bulbs for the amber "on" indicator:
Part # 18691-05041 (gray base)

If you need any pointers on removing the center console, then the subassembly holding the switches, then the switches themselves, that memory is fresh. Let me know if you need a how-to on that.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
QUOTE (DSHornet @ Nov 20 2010, 06:22 PM) index.php?act=findpost&pid=373442
Funny you should mention this. Not three weeks ago, I had to replace the little bulbs in my seat heater switches that light up the seat icons. I ordered two of each from my local dealer because neither of us could tell from the drawing in his illustrated parts breakdown which bulb was for which function. Total cost to order the four bulbs was around US $24 (your price may vary). I don't know if the same part numbers are used in the rear defroster switch.

The bulbs for the seat icons:
Part # 18691-08041 (black base)

The bulbs for the amber "on" indicator:
Part # 18691-05041 (gray base)

If you need any pointers on removing the center console, then the subassembly holding the switches, then the switches themselves, that memory is fresh. Let me know if you need a how-to on that.




Thanks for the help! Just took the switch out this morning, so no problems with that.
 

·
Registered
Joined
·
2 Posts
Hey -- I too need to replace the bulb on my 2003 Santa Fe rear defroster switch - the on bulb works, but hte button light does nto - making it hard to locate at night. I also need to replace teh bulb in the TCS switch - can not find a listing for it, bt I got it out ( I haven't figured out how to remove the Defroster one. Also ther 'D' does not light up when in drive inthe instumentr cluster -- Any info on how to repair this too?? It does amaze me that next to the TCS switch - teh Pheostat doesn't seem to be illuminated - kind of dumb!.
 
1 - 4 of 4 Posts
Top