Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello,

I am new to this forum, i own a Hyundai Sonata Hybrid 2013, 118K miles the problem is that car vibrates when in high gear and low rpm on engine, after downshifting vibration goes away (when rpm goes high) when accelerating hard there is no vibration only when touching gas pedal slightly and coasting. Rebuilt transmission this week, service replaced whole pack of friction disks and several solenoids, with new oil filter and oil, car shifts smooth and feels more torque but the vibration is still there, makes me wonder that the problem is not inside the trans. Had 2018 camry 2.5 with 40K miles (Sold) with the same vibration, so how can my old sonata with high miles and a new car have the same symptom, I think the problem is in other part. I really like this car has a great mpg, rides good and really want to keep it. Any help and suggestions will be highly appreciated.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
get the mounts verified. could also be carbon build up on the valves, will need a decarbonisation process or a decarbon spray.
Went to service today, everything is fine as they diagnosed, no codes, all mounts good… only left is hybrid flywheel, that needs trans removed again :D… will check that this week. If not flywheel no one has an idea what is causing the vibration, to explain the feel better: when driving a manual car uphill and needs a downshift for torque, this only happens when the engine is running.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
I find my car vibrated a little bit more when driving around 35-40 mph, a speed where computer shifts to 6th gear but rpm can barely make it. Downshift to 5th make engine a little happier. You can feel the car vibrate slightly more but doesn't affect driving. Not sure if that's your case?
Yeah, in same situation vibration was low but over time got harder. New suggestion is the TCU, changes gear too soon for engine to have torque for that speed.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Hello,

Rebuild was cheap in my region, thats why i tried, still no good news, will post when i find a fix.

Thanks fir your feedback!

My 2014 does the exact same thing. At this mileage, I wouldn't spend all that money rebuilding the transmission and all that. The car runs fine. It is old. It will vibrate a little. It's all good.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top