Hyundai Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
27 Posts
Wow!
Thanks for replying. Couple more questions if you have the time. Did it ever work correctly every time? What was your dealer - sounds like ai should avoid them.
A bit more background. Mine (Santa Fe) worked correctly from new (2/2021) until the first software upgrade (~11/2021) after which, when changing profiles, the seat would take up to 60s to move to the correct position and would move even while driving if one set off with the seat in the other profile's position. After the latest upgrade (4/22) the seat many never move to the correct position but if one changes back to the old profile (seat doesn't move as its in the correct position) then back to the new profile the seat will move instantly. And sometimes after driving the car, locking, unlocking and powering up the other profile is active. Otherwise, we haven't see any of your other defects.
 

·
Registered
Joined
·
27 Posts
Each profile has two seat settings which are set on the drivers door. I have my car setup such that seat position #1 (wife) is the same position for both profiles and #2 (me) is the same on both. When you switch profiles the seat will move to the last memory position that that profile used. So, for my profile I last used #2 and for her profile she used #1. If I was the last to use the car when she turns it on it will move the seat to #2 (we use the move the seat all the way back when car is turned off feature) and the Nav screen will offer to switch profiles, she does and the seat moves to position #1.
 

·
Registered
Joined
·
27 Posts
Thanks for the response - I understand your position. Your car history makes me nervous that we have the same issue - I'll have to make more settings unique to each user and see if any act up.
 

·
Registered
Joined
·
27 Posts
Driver seat unexpectedly moves while driving down the road?????
Yes, normally the seat will move after 30 seconds or so by which time I have reversed out of the garage onto the road and I'm just setting off in drive but occasionally it's taken longer (or I've maneuvered quicker :) ) and I'm half way down the road and the seat starts to move back to my position while I'm travelling 25mph +. If you're wondering why I don't just push #2 on the door after switching profiles it's more out of frustration that it used to move immediately until the first upgrade and (as an engineer) I want to know when it will move. Once it didn't move at all before I reached my destination. Upon returning to the car the seat then moved from the engine off position (fully extended) to my position - that was an interesting data point.
We have an oil change coming up so we'll get the dealer to look at the issue but based on the OP's experience I'm not holding my breath.
 

·
Registered
Joined
·
27 Posts
OP - thanks for the valuable input!
Hitherto the only difference between the two profiles has been the seat and mirrors but after reading your earlier post I changed my dash theme and ambient lighting (although that is difficult to discern in daylight). So, I'll keep and eye on those settings too. One problem we have is we live in Tucson, AZ - bought the car in Phoenix and will be taking the car for service in Palatine, IL before returning to Tucson at the end of the summer - so, coordinating between dealers could be an issue if this goes on for a while :(

Thanks again for the feedback even though you don't have a dog in this fight anymore.
 

·
Registered
Joined
·
27 Posts
Maybe they should utilize a TDR to trace 'grounds' on each of the suspect computers.
I would agree were it not for the fact that the issue first arose immediately after the first upgrade last November (or so) and now after the latest upgrade the issue is even worse - before the seat would always move within 30 seconds or so now it's random if it moves at all. OTOH the OP's reporting the a new main board plus a complete reset didn't address the issue supports your position that it's an environmental problem.
 

·
Registered
Joined
·
27 Posts
You mentioned the 'upgrades'; were these downloaded nav updates or a platform-specific dealer install?
Both upgrades were via USB contains software downloaded from Hyundai’s website. While the upgrades were described as navigation upgrades they also changed the display screen layout and features e.g. sorting radio station presets
 

·
Registered
Joined
·
27 Posts
Another data point. After the OP mentioned that the ambient lighting was another setting that didn't change correctly I updated my profile with non default lighting and selected cluster theme B while my wife's profile remained with the defaults. Now, when starting the car and switching to my profile, the radio switches to my last station as it always did but the cluster theme, lighting and seat continue to reflect my wife's settings. However, if I switch back to her profile the radio will switch, but then switch to my profile will cause all the setting to be updated to mine!
So, now I have something that's definitive and demonstratable to the dealer. What I haven't figured out is how long it is after turning the engine off before the problem arises.
 

·
Registered
Joined
·
27 Posts
Another data point. I discovered if I get into the car after my wife drove it last that when the "Select Profile" screen appears then, rather than select my profile, let it timeout and then pick Select Profile from the main screen and then select my profile the seat will move immediately to my position. This works 100% of the time at the expense of waiting for the the timeout ~20s.
 

·
Registered
Joined
·
27 Posts
Had the service appt today. Gave the service manager a one sheet description of how the seats and profiles were setup, how the system functioned prior to the s/w update, the problem since and the workaround.
After 90 minutes SM reported that it was fixed. Service notes stated that the tech had confirmed the issue,then performed a CAP Reset which reset all computers and confirmed the system now operated as expected. Stupidly I believed him and drove home without testing. After arriving home I waited 4 minutes (I found this is the shorted time you have to wait for the system to shutdown and then fail), started the car switched profile and nothing - seat didn’t move cluster theme didn’t change.

I then tried the System Reset from the Setup -> General -> System Info screen. That wiped out both profiles but upon reading them the problem persisted.
After googling some more I found the is a hidden Engineering menu that you can get to by:
Turn radio to FM, volume to 2. Go to settings -> general, go to the software info tab. Tap 5 times just to the left of the Update button, then once to the right of it. That should bring up a password prompt, 2702 worked for me. Once there there is a Factory Reset option under the Variant Coding menu option. Press that and confirm, after a few minutes the new profile screen appears just as it did the day you bought the car. After setting up both profiles the system now moves the seat 13 seconds after switching profiles - just like it should!
 

·
Registered
Joined
·
27 Posts
I performed the factory reset and then rebuilt my wife’s and my profile. It did indeed work twice! If I go back to the original suggestion and wait for the one screen prompt at start up times out, and then go to change user, it works every time. Apparently the pop up start up screen does not work properly to actually change the user. It was still a PIA to reload my FM and XM stations, and other setting again after the reset. I wont do it again until Hyundai fixes the issue.
Sorry, j should have updated my post. It worked for us for 5 days or so - maybe 4 changes of driver. Then it stopped working when switching back to primary (wife) but still works for me.
I did persuade my dealer to forward my problem description to Hyundai - I’ll update if I get any feedback.
 
1 - 15 of 15 Posts
Top