Hyundai Forums banner

21 - 36 of 36 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #21
The reason for that is because the version that I selected is a 10.4' screen where as the one that sits flush in the dash is 9.7. However, the 9.7' was a 4 core px6 CPU and I opted for the intel 9853i octa core on the 10.4'.
 

·
Registered
Joined
·
2 Posts
Looking forward to hearing more @2XPLICIT . I'm seriously considering doing this too (my original head unit is dead and out of warranty) but am nervous about finding the right one out there. Do you have direct contact for the dealer/seller that you can share so i can ask questions? Thanks
 

·
Registered
Joined
·
3 Posts
I really hope this thread isn’t dead, I’d love to have an update of how the headunit is holding up And if it’s worth investing in
 

·
Registered
Joined
·
283 Posts
Discussion Starter #24
Update everyone,

The tesla android unit is amazing. I finally got the oem backup camera to work. Inhad to purchase the axxess 12v - 6v adapter for the hyundai oem backup camera to work. I didnt have a wiring diagram so i had to go to a friend of mine to have it installed at his shop. So, i will be posting pictures tomorrow of the new setup. Please ask any questions.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #25 (Edited)
Ok guys,

Here how it looks after the hyundai logo boot up. Takes less than 5 seconds to boot up.

445270



It has a beautiful home screen... Now there are like 20 wallpapers to choose from or you add your own wallpaper and replace the car.

445271


Nice climate control screen... However, I contacted the engineers to see if I can change the color from the red yellow to a Blue White.....

445272


This is the radio screen.... As you can see it supports all the cool stations lol... AM side includes 590, 640, 680, 1010 etc... AM side I had some issues with Radio frequencies due to the unit not being fully configured. I had to get into the engineering options and enable the Radio Power Antenna option and change the Radio Frequency Region to North America. It now works perfectly.

445273


Here it is folks....

Original OEM Backup Camera support.... The quality is actually High Definition... My photo taking capabilities are definitely not good with the phone.... The unit again was not configured for the reverse assistant lines. Engineering advised me to go into their menu and enable them. As you can see you can also adjust the lines to your preference.
So far so good.... Also, an Axxess 12v-6v adapter is required to integrate your OEM Factory Back up Camera.... 12v to 6v Adapter

445274


Android apps screen..... Pretty god **** cool.... As you can see I have a cool plexi glass screen protector on the screen aswell....

Parking sensors also work fine if I did not mention that......

Let me know what you all think???

Also, let me know what else you'd like to see...
 

·
Registered
Joined
·
2 Posts
Looks pretty great! Can you please just back-up with the camera so we can see the top view of how it meets the dash and protrudes from the dash generally? Also, any tips on the physical install? Special tools needed etc.?
 

·
Registered
Joined
·
283 Posts
Discussion Starter #27
Here is a picture on how it protrudes from the dash. There are smaller Tesla style screens that are embedded into the dash for a more factory OEM look.
445275


You can purchase these from Ebay, Amazon, Local sellers here in the GTA. Just do a google search. There isn't any tips that I can give. They claim its plug n play... The harness that you will receive will be plug n play. However, please ensure that the unit you purchase support all your current OEM features and functions. Be prepared to make some modifications. Such as adding steering wheel control adapters, 12v to 6v step down adapter. Your unit might also come fully configured. Unfortunately, mine did not. Every vendor, distributor will carry different manufactures. Find one that you like.

Here is a video on youtube on how to remove your Santa Fe Radio... Enjoy.... Have fun finding your favourite android unit.

Santa Fe Radio Removal
 

·
Registered
Joined
·
5 Posts
Hello i have a hyundai santa fe dm 2015 with a sound system with a amplifier but it is not jbl or infinity the car is a erupean version i live in sweden =) ,(dont know if it matters) the amplifier is a AMP_150DM and the head unit in my car is the one with navigation.i recently bought a tesla style stereo with a px6 core from aliexpress, and it does not work in my car i get no sound from it and i can´t control my ac or the fan speed with the stereo. do you know what is wrong??
tried to get help from the seller eand he sent me new canbus devices, but they did not work it was exactly the same as the one i got with the stereo.
this is a picture of my original stereo in the car
445585
Best regards fredrik
 

·
Registered
Joined
·
283 Posts
Discussion Starter #30 (Edited)
Mr. Fredrik, I noticed that you just joined the Hyundai Forums 1 day ago. Welcome to the Hyundai Forums.

You have selected a great android unit. However, I found out just like you that these units claim that they are plug n play but they really are not. However, once they are setup and configured correctly they are amazing. I am assuming they have provided you with instructions on the installation.

Few questions need to be answered.

The original head unit is it an OEM Hyundai unit or is it aftermarket?

The amplifier you mentioned is not JBL or Infinity. I looked it up and it comes up as a 2012 Santa Fe amplifier. Maybe they might used it for later years.

Now the seller should offer different harnesses one without factory amplifier and one with factory amplifier. Make sure you confirm that they sent you the correct harness.

When you connect the harness make sure it plugged in very firmly and listen for the click.

Then from the harness make sure that your canbus is firmly connected and plugged into the right spot on the back of the unit.

Plug in your USB connector to the right port on the back.

There should be another cable with the audio inputs and outputs. Make sure you have the cable plugged into the right port at the back.

Then make sure to plug in FL OUT to FL IN and FR OUT to FR IN.

The unit may also need to be setup by region, so please ask them how to get into their engineering settings and configure it for Europe. Mine was setup for China and needed to configured for North America.

Also, make sure they walk you through setting up your canbus as mine was set for a different make and model. Once we configured it for Sonata 8th Gen everything started working. Yours may need to be set to Sonata 8th Gen or ix35/45. Not sure but please confirm with the seller. They need to consult their distributor.

Not sure if your harness is the same but here is a diagram that was provided to me.
445617


RCA RED and WHITE GETS CONNECTED TO YOUR AMPLIFIER. Your unit should have another cable that has all the inputs and outputs.

Example:

445618


Only one connection you will have to make and that is FL (White) to FL (White) and FR (Red) to FR (Red).

The android unit sends the audio to amplifier which then disperses it to all speakers. you will have no control using fade or balance.

Please make sure your antenna cable is plugged in.

Please try that and report back. Steering wheels control is another issue. There is a pink wire with a clip try unclipping that and leaving it disconnected and then retest steering wheel controls.

Good luck.
 

·
Registered
Joined
·
2 Posts
Mr. Fredrik, I noticed that you just joined the Hyundai Forums 1 day ago. Welcome to the Hyundai Forums.

You have selected a great android unit. However, I found out just like you that these units claim that they are plug n play but they really are not. However, once they are setup and configured correctly they are amazing. I am assuming they have provided you with instructions on the installation.

Few questions need to be answered.

The original head unit is it an OEM Hyundai unit or is it aftermarket?

The amplifier you mentioned is not JBL or Infinity. I looked it up and it comes up as a 2012 Santa Fe amplifier. Maybe they might used it for later years.

Now the seller should offer different harnesses one without factory amplifier and one with factory amplifier. Make sure you confirm that they sent you the correct harness.

When you connect the harness make sure it plugged in very firmly and listen for the click.

Then from the harness make sure that your canbus is firmly connected and plugged into the right spot on the back of the unit.

Plug in your USB connector to the right port on the back.

There should be another cable with the audio inputs and outputs. Make sure you have the cable plugged into the right port at the back.

Then make sure to plug in FL OUT to FL IN and FR OUT to FR IN.

The unit may also need to be setup by region, so please ask them how to get into their engineering settings and configure it for Europe. Mine was setup for China and needed to configured for North America.

Also, make sure they walk you through setting up your canbus as mine was set for a different make and model. Once we configured it for Sonata 8th Gen everything started working. Yours may need to be set to Sonata 8th Gen or ix35/45. Not sure but please confirm with the seller. They need to consult their distributor.

Not sure if your harness is the same but here is a diagram that was provided to me. View attachment 445617

RCA RED and WHITE GETS CONNECTED TO YOUR AMPLIFIER. Your unit should have another cable that has all the inputs and outputs.

Example:

View attachment 445618

Only one connection you will have to make and that is FL (White) to FL (White) and FR (Red) to FR (Red).

The android unit sends the audio to amplifier which then disperses it to all speakers. you will have no control using fade or balance.

Please make sure your antenna cable is plugged in.

Please try that and report back. Steering wheels control is another issue. There is a pink wire with a clip try unclipping that and leaving it disconnected and then retest steering wheel controls.

Good luck.
[/QUOTE

Hi 2XPLICIT, thanks for posting the review and pics. Do you have a picture of the 12-volt to 6-volt Step-Down Converter connection?
 

·
Registered
Joined
·
5 Posts
thanks
the original headunit is a hyundai one never changed it model LAN2100EHDM
took some pictures ot the stereo and the wiring harness, tried to change some protocols for the canbus but no luck.
still no sound i even tried with another canbus decoder (got 2 extra from the seller)
when i google my amplifier and the jbl one, the connections looks the same so must be something else or??
do i need to connect the amp wire from the android stereo??
445632


445627
445628
445629
445630
445631
 

·
Registered
Joined
·
283 Posts
Discussion Starter #33 (Edited)
Yours is a lot different than mine. However, the functionality should be the same. That cable with the amp wire is if you are to run an external amplifier. You have a factory built in amplifier. They should have given you a harness adapter that plugs into your factory harness. I noticed that yours says Sonata 8th Gen. Make sure it's the correct harness for the Santa fe.
Example of my harness -
445637



From there you should have 1 Canbus Decoder Box and 1 SPDIF BOX looks just like the canbus box but says SPDIF.

Example: the image below is me trying to figure out the reverse camera but as you can see there are two decoder box. 1 canbus and the other spdif. In my case I required a 12v to 6v step down adapter by access interfaces. I had to go to a shop to purchase it and have them splice in the adapter to get the reverse camera to work.




445638



From the SPDIF you will have all the RCA connections.

445639


From the main harness you will see two rca connections FL and FR.
That would get plugged into FL and FR. Only front speakers will be connected. I believe they may have provided you with the wrong harness for your vehicle..

Hope this helps. I was provided with a similar cable to run an external amp aswell but I am using the Infinity factory amp hence why I have the SPDIF Box to control the amplifier. From the unit. I can actually turn the Infinity Amplifier Volume/Gain up. I can also turn up the volume on the built amp on the unit aswell.. They need to advise you which settings you should select when in their engineering settings. Please check the harness as I feel that you were not given the correct harness. If so check and make sure they provided you a SPDIF DECODER BOX which will enable you to use and retain you factory amplifier. Please let me know.

Climate control - Canbus settings. Not sure if it's the same but here is a pic of how mine is set.

445642




Good luck.
 

Attachments

·
Registered
Joined
·
5 Posts
sorry for late post, but we just baught a new house =)
i am thinking to buy a new unit, i think i got the wrong cable or something for my car
but the thing is i cant just order a new cable =(
wich stereo do you recommend for my santa??
 

·
Registered
Joined
·
77 Posts
thanks
the original headunit is a hyundai one never changed it model LAN2100EHDM
took some pictures ot the stereo and the wiring harness, tried to change some protocols for the canbus but no luck.
still no sound i even tried with another canbus decoder (got 2 extra from the seller)
when i google my amplifier and the jbl one, the connections looks the same so must be something else or??
do i need to connect the amp wire from the android stereo??
On my non-tesla-style unit I also had no sound out of the box. I fixed it by doing this (which may not be the same for you, but you never know):

...the head unit needs to be hooked up so that the Front left and right RCA plugs going to the CANBUS/SPDIF box.

In Car Info > Audio-A make sure to center every setting. Ignore the numerical value that shows up, the center is the proper setting.

For me these were:
  • Sound at 25 instead of 0.
  • FAD at 10 (50% front, 50% rear) instead of 0.
  • BAL at 10 (50% left, 50% right) instead of 0.
  • Treble at 0 instead of -10.
  • Middle at 0 instead of -10.
  • Bass at 0 instead of -10.
In the equalizer app turn off Surround Sound as it relies on the rear channels to work and with the Infinity system, we lose the rear and sub channels (they get recreated from the front channels instead). I'd suggest turning it off in general since it's only good for the driver and bad for everyone else anyway.

Also in the equalizer app I suggest turning on Loudness (tap Settings button on the screen with all the sliders) so that you have some bass at lower volumes. I also use Preset Mode 1 and have Bass Enhancement to 4 at < 68hz I think. I'm still changing these all the time to find a good balance between sound quality at lower and higher volume. An alternative that I didn't mind was leaving the equalizer flat, no Loudness, no Bass Enhancement, and just turning the Treble slider (which is really Bass) in Audio-A.
As for which CANBUS protocol to use, I was able to tell by the imprint on the plastic of the CANBUS box. It had a brand name, and there was a matching protocol in the CANBUS settings. Under that I chose the 'GM' option (IX45 also worked I believe).
 

·
Registered
Joined
·
1 Posts
Mr. Fredrik, I noticed that you just joined the Hyundai Forums 1 day ago. Welcome to the Hyundai Forums.

You have selected a great android unit. However, I found out just like you that these units claim that they are plug n play but they really are not. However, once they are setup and configured correctly they are amazing. I am assuming they have provided you with instructions on the installation.

Few questions need to be answered.

The original head unit is it an OEM Hyundai unit or is it aftermarket?

The amplifier you mentioned is not JBL or Infinity. I looked it up and it comes up as a 2012 Santa Fe amplifier. Maybe they might used it for later years.

Now the seller should offer different harnesses one without factory amplifier and one with factory amplifier. Make sure you confirm that they sent you the correct harness.

When you connect the harness make sure it plugged in very firmly and listen for the click.

Then from the harness make sure that your canbus is firmly connected and plugged into the right spot on the back of the unit.

Plug in your USB connector to the right port on the back.

There should be another cable with the audio inputs and outputs. Make sure you have the cable plugged into the right port at the back.

Then make sure to plug in FL OUT to FL IN and FR OUT to FR IN.

The unit may also need to be setup by region, so please ask them how to get into their engineering settings and configure it for Europe. Mine was setup for China and needed to configured for North America.

Also, make sure they walk you through setting up your canbus as mine was set for a different make and model. Once we configured it for Sonata 8th Gen everything started working. Yours may need to be set to Sonata 8th Gen or ix35/45. Not sure but please confirm with the seller. They need to consult their distributor.

Not sure if your harness is the same but here is a diagram that was provided to me. View attachment 445617

RCA RED and WHITE GETS CONNECTED TO YOUR AMPLIFIER. Your unit should have another cable that has all the inputs and outputs.

Example:

View attachment 445618

Only one connection you will have to make and that is FL (White) to FL (White) and FR (Red) to FR (Red).

The android unit sends the audio to amplifier which then disperses it to all speakers. you will have no control using fade or balance.

Please make sure your antenna cable is plugged in.

Please try that and report back. Steering wheels control is another issue. There is a pink wire with a clip try unclipping that and leaving it disconnected and then retest steering wheel controls.

Good luck.
I have santa fe 2016 steerkng wheel working but sound no working i have many cables RCA maybe need amp to work how can give ordrr to amp to work
 
21 - 36 of 36 Posts
Top