Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, I have a 00 hundai elantra 2.0. Well was driving to work and at a stop light the car suddenly died! Got it towed back to the house started looking around for the problem. The tow company sprayed starting fluid into the air box and it did felt like it wanted to start up, so the sparks from the spark plug is eliminated. So my next test was I popped out the fuel rail and cranked it so no fuel was pumping out. Hmmm so I did replace the fuel pump and the strain and tryed to start and still not getting any fuel(tank is half way full btw). So I did the relay switching around and still nothing, I also don't hear the fuel pump engaging on when I try the key on! My next step would be to test at the fuel pump connector for power? Test the fuel pump relay? I did pop out the top pipe from the fuel filter and tryed to crank it but no fuel was spilling out, I did not though pop out the fuel line on the bottom of the fuel filter? Really need help please.

Thanks
 

·
Registered
Joined
·
5 Posts
Hi, I'm currently experiencing the same problem! I have a 1999 Hyundai Lantra sportswagon 2lt, and it keeps stalling at lights and when it idles for longer than 30sec-60sec. I've changed leads, I'm awaiting a new coil, but it has been mentioned to me (by my partner who has driven it) that it may be a fuel problem, just like you have mentioned! The car also splutters intermittantly, like it's going to stall, then runs fine.
Can someone please provide some helpful advice/solution to this problem!!
Thank you
:liebe011:
 

·
Registered
Joined
·
5 Posts
QUOTE (deziking @ Apr 25 2010, 10:14 AM) index.php?act=findpost&pid=316435
Hello all, I have a 00 hundai elantra 2.0. Well was driving to work and at a stop light the car suddenly died! Got it towed back to the house started looking around for the problem. The tow company sprayed starting fluid into the air box and it did felt like it wanted to start up, so the sparks from the spark plug is eliminated. So my next test was I popped out the fuel rail and cranked it so no fuel was pumping out. Hmmm so I did replace the fuel pump and the strain and tryed to start and still not getting any fuel(tank is half way full btw). So I did the relay switching around and still nothing, I also don't hear the fuel pump engaging on when I try the key on! My next step would be to test at the fuel pump connector for power? Test the fuel pump relay? I did pop out the top pipe from the fuel filter and tryed to crank it but no fuel was spilling out, I did not though pop out the fuel line on the bottom of the fuel filter? Really need help please.

Thanks
Hi, I may have found the problem, I haven't tried it yet,I'm awaiting the part, apparently it's not uncommon in hyundai's , the crank angle sensor!, the roadside assisst mechanic isolated the problem to that, and from what you've explained and what I've also experienced, he said that it's characteristic of that part failing! I hope it's helped if you hav'nt already found your problem.
 
1 - 3 of 3 Posts
Top