Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter #1
Got under the car to do it's first oil change after a new engine 3,500 miles ago, and there was oil all over the plastic splash guard. Took it off, and notice the oil leak from the oil feed line, which was replaced when the long block was changed at 94k miles, around 2 months back.

The new engine has definitely made the car much more responsive off the straight line. On the previous engine, I could feel the difference between regular and premium fuel, the car reacted to it. With the new block, there is minimal difference whether on regular or premium.

Anyway, the oil came out quite dirty at 3,500 miles but nowhere close to the jet black it came out on the older engine. In went 5w40 Pennzoil Platinum and the Frame XG9688 filter. Now need to get the oil leak taken care of under warranty. And the steering coupler seems on its way out for the third time. Will try get this covered before the 10 yr/100k warranty runs out in 2,500 miles.

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
5,506 Posts
That pipe cannot be reused without it leaking. They should have installed a new one with the new engine.
 

·
Registered
Joined
·
404 Posts
That pipe cannot be reused without it leaking. They should have installed a new one with the new engine.
And make sure they are using the latest revision of this part. It makes a difference.
 

·
Registered
Joined
·
330 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter #6
Went back to dealer and they fixed the leak by torquing the oil feed line bolt again to the correct specs. This is after they said they have to do an oil consumption test on the new engine block and wanted to do an oil change. I said there is obviously a lot of oil leaking somewhere due to the undercarriage having all the oil kicked up, and I had to drop in an extra quart of oil last weekend to get the dipstick back to the F line.

8K miles on the new long block so far, and the car accelerates amazing.
 

·
Registered
Joined
·
7,564 Posts
The Genesis Coupe has issues with the turbo oil lines. Feed line leaks and the return line weeps. I replaced the factory feed line with a SS braided one with AN flare ends and a pressure restictor/reducer. Return line I used some 1/2" oil cooler hose. OE is silicone.
 
1 - 7 of 7 Posts
Top