Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
09 180k Only sometimes the trans feels like it's stuck in second gear as it goes to about 4000 RPMs at 70 miles an hour. Usually if you turn the car off wait a minute restart it it will be okay it's like a glitch somewhere. Did a trans drain & fill last summer, level is good, no cell ideas?

Sent from my KYOCERA-E6560 using Tapatalk
 

·
Registered
Joined
·
49 Posts
Discussion Starter #2
This is on again off again for a couple days and then it goes for a week or two with no problem now it just started in failsafe mode what should I look at
 

·
Registered
Joined
·
17,552 Posts
Scan the thing
 

·
Registered
Joined
·
17,552 Posts
0745 reflects concern with PCSV "A" ,, circuit open or short.. or valve fault.. or PCM / TCM fault


0328 reflects concern with knock sensor,, poor connect / short to power in signal circuit / knock sensor / PCM,,, BUT,, there is a PCM UPDATE to address the 0328 DTC...

Visit dealer and have update installed

13-FL-012

Description:

This bulletin provides information for an ECM diagnostic code logic update on some Accent 1.6L
vehicles that may experience the following DTC:

- P0300: Random/Multiple Cylinder Misfire Detected.
- P0301: Cylinder 1 - Misfire Detected.
- P0302: Cylinder 2 - Misfire Detected.
- P0303: Cylinder 3 - Misfire Detected.
- P0304: Cylinder 4 - Misfire Detected.
- P0128: Coolant Thermostat (Coolant Temperature Below Thermostat Regulating Temperature).
- P0328: Knock Sensor 1 Circuit High Input.
- P0461: Fuel Level Sensor A Circuit Range/Performance.
 
  • Like
Reactions: Voivod

·
Registered
Joined
·
2 Posts
Having the same issue with an 09 with 174k miles. Trans will sometimes stay in 3rd, especially after it rains or gets cold (below 50F). Check Engline light comes on, stays on for 2 days, then turns off. It's recently been getting hot at idle as well (temp warning lamp turns on at stop lights, turns off when moving). Flushed the fluid twice, looks totally fine, mechanic said he couldn't find anything wrong.

Any ideas? I'd rather not replace the trans if that's not the issue.

Edit: called the dealer and they said there's "no update for an 09 that would fix the knock sensor". Should I go to a different dealer?
 

·
Registered
Joined
·
2 Posts
They found the problem after I brought it back a second time. One of the eyelets was busted to heck and needed to be replaced. Something about it not being grounded properly to the engine block. All fixed. $3 part.
 
1 - 8 of 8 Posts
Top