Hyundai Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I am new to here and glad to have found this forum. I recently purchased a 02 trajet petrol and am delighted with it for space and comfort etc. The timing belt had been done just before I got it. I have noticed that when driving it has a severe flat spot at times, and totally lacks power. I was told it may be the timing but have double checked that and it is perfect. These cars are meant to be very lively and pwerful to drive but mine seem sto have a prob in this area. Has anyone come across this before or is this the way they are meant to be? Any help or advise would be great.
 

·
Registered
Joined
·
460 Posts
QUOTE (heimess @ Jul 17 2010, 03:59 PM) index.php?act=findpost&pid=342467
Hi I am new to here and glad to have found this forum. I recently purchased a 02 trajet petrol and am delighted with it for space and comfort etc. The timing belt had been done just before I got it. I have noticed that when driving it has a severe flat spot at times, and totally lacks power. I was told it may be the timing but have double checked that and it is perfect. These cars are meant to be very lively and pwerful to drive but mine seem sto have a prob in this area. Has anyone come across this before or is this the way they are meant to be? Any help or advise would be great.

The 2.0l pre 2004 was not very powerful and does suffer from flat spots/lack of power. It is very similar to the Mitsi EVO engine so if you want more power ???.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top