Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Okay, here goes. I bought a used 2014 Elantra SE Sedan with 40k miles on it and a warranty. Had the car a week and the TPMS light comes on, blinks for a minute and stays on (owners manual indicates this is a fault) . The indicator was reset by a shop and it lasted for about 24 hrs. Now I have to take it in again. (I have had the car less than 10 days. I drive the same route to work every night (about 12 miles). I have the factory XM radio and it is activated. I do not have rear camera or Nav System. I have not used the 12V DC charger plugs in the cabin, but I have used the USB and Aux hookups. My tires are at exactly 33psi. Checked and rechecked and verified at shops. ( I believe the light comes on after the tire loses 15% of it's pressure) in theory anyway..
My questions are these. Any ideas as to what to do if the shop can't fix this the 2nd or 3rd time I take the car in ? and if they can't will the car pass Virginia State Inspection with this light on ? (If I cover the light with a piece black tape) The Important thing I guess is if they can't fix it can I get the dealer to take the car back because If it doesn't pass State Inspection I'm screwed.
 

·
Registered
Joined
·
14 Posts
Hi so I have some similar issues but I just want to confirm. I recently purchased 4 brand new Genuine Hyundai TPMS sensors(Part number:52933-3X200) and had them installed by the local mechanic because of the one minute-ish blinking followed by a solid light(Orange horseshoe looking with exclamation point). The mechanic also reprogrammed. Totaled to be 260 USD. I drive about 10 miles and the light comes back on. I take back to mechanic two more times where he attempts to reprogram and each time after a few miles the light comes back on. Finally I ask the mechanic for a print out of the fault code. I attached below. I figured this C1306 RF internal Interference Failure may be just because this mechanic doesnt have the proper skils/equipment to perform the reprogramming. So I take the Hyundai dealership and they perform a reprogramming of the sensors and charge 130 USD. I drive about 10 miles down the road and again the light comes on. Anyone know what this error code could be or how to solve? As I initially drove the vehicle I made sure to unplug the dash camera and shut off my wifi and Bluetooth on my cellphone just in case that may be causing some type of RF internal interference as Fault code says. I dont want to throw anymore money at this problem blindly as I've already done. Any help is much appreciated.
 
1 - 2 of 2 Posts
Top