Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello from Australia.

I am not sure if this has been already answered but I can't seem to find it on the forum.

I have a 2004 Terracan 3.5L G6CU engine and it has been giving me some issues lately. It has done 210 xxx kms and I have recently replaced Oil, filters, coolant, spark plugs and belts.

It has been having a rough idle , bouncing up and down and it has gotten really bad lately. There has been no engine light and no error codes stored which is frustrating . Standing at the lights , the engine will shake as if there is a misfire but plugs and leads are fine.

Today there has been no power going up hill and there is a weird knock when I floor the pedal . Cold starts are weird as well , the engine will Rev up to 2000 rpm and stay there for a while then drop back down.

Does anyone have any suggestions or thoughts on this issue?

Thanks in advance!
 

·
Registered
Joined
·
138 Posts
sorry to say most UK terricans are diesel, therefore limited knowledge.
try searching for engine specific rather them model info.
Engine being used in many other models.
 

·
Registered
Joined
·
1 Posts
Hello from Australia.

I am not sure if this has been already answered but I can't seem to find it on the forum.

I have a 2004 Terracan 3.5L G6CU engine and it has been giving me some issues lately. It has done 210 xxx kms and I have recently replaced Oil, filters, coolant, spark plugs and belts.

It has been having a rough idle , bouncing up and down and it has gotten really bad lately. There has been no engine light and no error codes stored which is frustrating . Standing at the lights , the engine will shake as if there is a misfire but plugs and leads are fine.

Today there has been no power going up hill and there is a weird knock when I floor the pedal . Cold starts are weird as well , the engine will Rev up to 2000 rpm and stay there for a while then drop back down.

Does anyone have any suggestions or thoughts on this issue?

Thanks in advance!

Hey buddy,
i encounter the same problem at the moment. did you get to the bottom of it?
 
1 - 4 of 4 Posts
Top