Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi people
Got a saab t25 on it's way ready to get bolted up!!! Also be adding a front mount intercooler, fuel pressure reg, and walbro 255l/ph copy fuel pump.
Also im in process of giving the scoupe a good service. head gasket timing belt filter etc.
I know that we have rediculousley low C/R (7.5-1) and the car is setup to run rich!!! What im wondering is with the T25 in place at what psi of boost will the stock fuel setup run lean?
If nobody has hands on experience i can hire the local dnyo and use the lambda probe to work this out myself.

Cheers
 

·
Registered
Joined
·
125 Posts
the original injectors are small ->about 200ccm! they reach for round about 150HP...I use 326 ccm Injectors they have a rich a/f until 1,5bar with the T25! But the main problem you will have is the hotwireairflowsensor...the T25 produces too much airflow so the ECU got a error an cut the fuel and the ignition, this did not depent on the pressure! it depend on the air temperature and airmass whitch the turbo suck in
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
Are you using megasquirt or any thing to control the injectors and get around the hotwire fuel cut? my car has 2 maf sensors resistors i think one attatched to the inlet plenium and one bolted to the bulkhead that dont have anything plugged into it!? on another note my clutch is starting to slip!! iv found a sports clutch kit on ebay for £115 but im wondering if its going to hold up with the t25 on ?? what are you using bud??
 

·
Registered
Joined
·
125 Posts
the megasquirt I use in a other S-Coupe (I have about 5 S-Coupe's)

the thing on the bulkead is only for the LED's in the Tachometer to show the pressure...if you are not good with electronics to build yourself a cirriut then you could you a Apexi SAFC, there you could setup the Hotwiresensor and adjust the airmass...the injectors are working fine with the stock ecu as long you use high impedance injectors!

the clutch is already slipping with a T15 @ high boost...I don't know the ebay clutches..I use clutches from Clutchnet.com they are cheap and hold enough power (already testet wit a T3 charger @ 2bar boost) in my 1/4mile Scoupe I use a 4Pad clutch and in my winter street Scoupe I use a 6 Pad clutch, the pressure plate is stock in my cars
 
1 - 4 of 4 Posts
Top