Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey all Im new here and searched for starting issues but found nothing like mine so i am going to ask your help.

The other night i rained very hard here...couple inches accumulation.

As i went to start my sonata this morning i turned the key the car cranked and starting making crazy knocking noises and sounded like it was misses as well...popped the hood thinking something broke but nothing...slight moisture under the hood as well...go to try again same thing..knocking, dash lights coming on and then it would stall...i finally did it a third time but now gave it some gas...did the same thing and i revved to about 3k rpm and it stayed running at high idle for moment then down to 1k which is normal at a cold start....after that first hard start it was starting fine...let it sit for about 4 hours at work...same issues started knocking and wouldn't start unless i gave it gas...but runs and drives with no issues and start fine afterwards.....if anyone has had this happen or any idea would be appreciated...im gonna start with a spark plug change and go from there.

thank you
 

·
Registered
Joined
·
749 Posts
check your crank pulley, it's likely separated. the knocking noise was the pulley portion, and the lights were as a result of the reduced drivebelt speed.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
i believe the problem was moisture somewhere in the electrical harness...last few days have dried up and the problem became less pronounced...will post if anything else arises
 
1 - 4 of 4 Posts
Top