Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,

New member here, bought a 2019 SF Ultimate 2.0T this summer. Currently has 7300 Kms on it. Driving yesterday (-25°C) my SF started making a slight shudder/ vibration and sounded like the engine was lugging a bit when I came to a stop. Putting it in neutral it smoothed out and sounded normal, but I now have this issue at idle when in gear.

Tried to call the dealership but the service bay wasnt answering (I live 4 hours away from the nearest dealer).

Thoughts?

Tks
 

·
Registered
Joined
·
761 Posts
Time to see the dealer. Could be a vacuum leak, ignition, or if and older 2.0T, I'd say another engine might be in the future.
 

·
Registered
Joined
·
184 Posts
Hi All,

New member here, bought a 2019 SF Ultimate 2.0T this summer. Currently has 7300 Kms on it. Driving yesterday (-25°C) my SF started making a slight shudder/ vibration and sounded like the engine was lugging a bit when I came to a stop. Putting it in neutral it smoothed out and sounded normal, but I now have this issue at idle when in gear.

Tried to call the dealership but the service bay wasnt answering (I live 4 hours away from the nearest dealer).

Thoughts?

Tks
Sounds like a misfire. Did you get a check engine light? I’d check your plug wires, at least make sure the wires are seated on the plugs. Maybe a local parts store can scan for a code.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
It drives perfectly...its only when I come to a start that I notice it... guess I'll plan a trip to the dealer
 
1 - 5 of 5 Posts
Top