Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Members I have a strange problem with my 1999 excel x3 manual
for some reason my hazards & interior light will only work when the engine is started & the battery dosent seem to charge.
I thought at 1st it was the alternator but now not so sure as I would have thought the that the fact that they work when the engine is started wuld mean its generating power.
I'm really stuck with this problem any ideas?
cheers for any help
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
14,614 Posts
I'm really stuck with this problem any ideas?
Grab a voltmeter/test light, switch on the ignition and check ALL the fuses...by probing the test points on top of each fuse (you don't have to remove them all). If you find a fuse that has 12V on one test point but something significantly different on the other you should replace that fuse.

 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
"
Hi Members I have a strange problem with my 1999 excel x3 manual
for some reason my hazards & interior light will only work when the engine is started & the battery dosent seem to charge.
I thought at 1st it was the alternator but now not so sure as I would have thought the that the fact that they work when the engine is started wuld mean its generating power.
I'm really stuck with this problem any ideas?
cheers for any help
""""""""""""""" r
eeeeeEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE
Are you saying the battery is flat? How do you start the car?
The battery goes flat from starting the car a few times Gerard I've kept a spare fully charged battery in the back & keep alternating & recharging them to start the car
 
1 - 4 of 4 Posts
Top