Hyundai Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi everyone, I recently purchased a 05 Getz and within a couple of weeks the stereo stopped working, I had to enter the code a couple of times after I left the car in the airport for a week and when I first purchased it but this is different, there is nothing in the screen, no power, the cd is still in the player, I was told it might be the fuse and checked the panel, the cover for the panel is missing (this has the details of what each fuse is for ) and the tool for taking out the fuses is also missing. (I found out this info from reading other posts in this forum) I need to know which fuse is the stereo, how to take it out and where to get a new fuse and how will I know if it's blown.
Thanks
Lenn
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,296 Posts
Welcome to the forum Lenn 00000732

Fuses for the radio highlighted below. The ones highlighted in purple are all spares, so you can use those to replace either of the others if it's blown. Just pick the one that's the same colour as the fuse that's blown. Looks like they should both be blue 15Amp fuses.

I normally suggest using a voltmeter to test ALL the fuse but since we already know what two fuses your looking for you'd be as well to just pull them off the fusebox and check them visually. You should find another fuse puller tool out on the engine bay fusebox, or you could just use a pair of long nosed pliers to pull them. You need to remove the yellow fuse carrier to get at the fuse inside it. Pull it outwards then press in from the sides to release it....I think.



 

Attachments

·
Registered
Joined
·
1 Posts
Tuscon 09 just wont start

Car turns over great , just completed a 356km drive ran as smoothly as anything .
Came to the car next day and car just wont start , it turns over , however it wont start , is this a common fault …..
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks Autospark ? That all makes sense, my fuse box is missing one of those in your picture but I'll try and look at the large yellow one and see if I can replace that
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I tried to send you a photo but can't firgure out how, basically my fuse box is identical to your except the top right one you circled, in mine it's a red 10amp not the blue 15, maybe this is why it blew to begin with ? Stereo was working fine when I purchased it but stopped after 3-4 wks.
Going to look at the yellow one now and I'll let you know how I get on
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Welcome to the forum Lenn 00000732

Fuses for the radio highlighted below. The ones highlighted in purple are all spares, so you can use those to replace either of the others if it's blown. Just pick the one that's the same colour as the fuse that's blown. Looks like they should both be blue 15Amp fuses.

Hi and thanks for helping, I checked both fuses as you suggested and they appear to be fine, although one is a 10amp (in my fuse box) any other suggestions of what it might be ?
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,296 Posts
Is anything else not working? Interior lamps & door ajar warning light on the instrument cluster OK? Power mirror adjusters working (if you have them)?

If it's not fuses then you'd need to remove the radio and check the power supplies and grounds at the connector behind the unit.

BTW, one of those fuses is actually supposed to be a 10A. The one in the yellow carrier is 15A, the other one should be a 10A.
 

·
Registered
2007 Honda CRV
Joined
·
4,577 Posts
As radio was working, and over time, stopped working ...
Would assume the radio died.
Check powers and grounds to radio.
If good then probably need new radio.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Thanks, I'll try that, although by taking the stereo out and checking the cables !! I'm not sure what I should be looking for ? How will I know if they are ok, (never done any of this stuff before ) #imawomanswhosnotusedtothis ???
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,296 Posts
Is it the original Hyundai radio? If so, there will probably be a fuse on the back of the unit, so check that first.
You'll need a voltmeter to check the power supplies on the radio connector. And probably a tool to release the radio from the dashboard.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
Not sure if it's the orignal stereo, I'll see if I can take it out and have a look, thanks ?
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,296 Posts
Hyundai stereos usually say Hyundai on the front of the unit. Below is the OEM stereo that's fitted to UK/European models...

 
1 - 12 of 12 Posts
Top