Hyundai Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Put this piece i got on amazon called Torque Solutions BOV sound plate on my 2018 sport and within 24hours i was getting a terrible gas fume smell and black carbon in the tail pipes. Sending it back today. Not really sure what or why because all does it vent to atmosphere with the need to remove the recirc hose. If anyone has any input let me know. 2018 sonata sport 2.0t. Im still new so it wont let me post the pic but just look at it in Amazon. And if you thought about getting it dont


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,093 Posts
Seen others installed on their < 2015 Sonatas and Kia Optimas and no issues like what you had. When you removed it, did all the smells/fumes go away? If so, maybe you were sent the wrong unit. Try working with amazon and/or the seller to make sure you got the correct part. And did you double check it was installed the right way and the O-rings sat nice and tight?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Seen others installed on their < 2015 Sonatas and Kia Optimas and no issues like what you had. When you removed it, did all the smells/fumes go away? If so, maybe you were sent the wrong unit. Try working with amazon and/or the seller to make sure you got the correct part. And did you double check it was installed the right way and the O-rings sat nice and tight?


Yea when i put it back to stock the smell instantly went away and no more issues. Yea I checked it and it was in right everything tight. I have no idea what the issue was unless they changed something on the 2018? But I sending it back for a refund I may just stick sick with removing the recirc tube but Now im worried that will mess something up lol


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
954 Posts
Which bov were you running?

I had one on my YF for a couple years without any issues, though you don't need to remove the recirc hose since the adapter just plugs the recirc hose from the bov side.

Did you reset the car (unplug the battery for a few mins) before driving it?
 

·
Registered
Joined
·
1,093 Posts
Which bov were you running?
He was using the BOV plate from torque Solutions.
Like this one:
[ame]https://www.amazon.com/Torque-Solution-Sound-Plate-Black/dp/B00KMAS8SO/ref=sr_1_6?ie=UTF8&qid=1532545412&sr=8-6&keywords=torque+solutions+bov+plate[/ame]
 

·
Registered
Joined
·
954 Posts
Wow just a plate, that's strange.

I know of one other person that had issues with a sound plate and his solenoid was bad.
 

·
Registered
Joined
·
1,093 Posts
That's why I was thinking it was wrong unit installed, or some other issue he has going on.
 

·
Registered
Joined
·
72 Posts
That's why I was thinking it was wrong unit installed, or some other issue he has going on.


I have a 2012 2.0t had it to the dealer multiple times for this exact reason and never once got a remedy or cause. To this day she still looks like she’s “smoking” even in summer with the carbon an crazy strong fuel smell and fumes just flowing out the dual exhaust. Everything is “mechanically” sound but just thinking she runs super rich?
 
1 - 10 of 10 Posts
Top