Hyundai Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've been having to change spark plugs every 2,000 miles or more. Car starts great, runs great until it warms up and after initial accelleration from stop or slow down. Will backfire and stutter shake lack of power when accellerating from stop or slow down. Once it gets going it runs fine until I have to stop again. Does not happen with new plugs however I have to change the plugs bi weekly then. The Ignition Coil firing order is not the same as what Hyundai recommends for this vehicle. Coil has firing order 14 first side and then 32 second coil. However Hyundai states that it must be 1342. I noticed as well that the plug that is totally full of carbon after only one or two tanks of gas is the 3/4 plug. Was told by a mechanic it does not matter, this may be from another year Accent. However, logically these are from two different coils receiving and sending current or whatever to sensors and computers. RIGHT? The Car runs great after the plugs are changed. Great upon start.
 

·
Registered
Joined
·
448 Posts
QUOTE (maddiemae414 @ Oct 6 2010, 12:47 PM) index.php?act=findpost&pid=361534
I've been having to change spark plugs every 2,000 miles or more. Car starts great, runs great until it warms up and after initial accelleration from stop or slow down. Will backfire and stutter shake lack of power when accellerating from stop or slow down. Once it gets going it runs fine until I have to stop again. Does not happen with new plugs however I have to change the plugs bi weekly then. The Ignition Coil firing order is not the same as what Hyundai recommends for this vehicle. Coil has firing order 14 first side and then 32 second coil. However Hyundai states that it must be 1342. I noticed as well that the plug that is totally full of carbon after only one or two tanks of gas is the 3/4 plug. Was told by a mechanic it does not matter, this may be from another year Accent. However, logically these are from two different coils receiving and sending current or whatever to sensors and computers. RIGHT? The Car runs great after the plugs are changed. Great upon start.
The firing order and the connection to the coils isn't the same thing. On a 4 cylinder, you normally have 2 sets of 2 pairs of pistons that go up and down together, so pistons 1 & 4 would go up & down together as would pistons 2 & 3. In each set, one piston would be on a compression stroke and the other on an exhaust, so to me, it's logical that plugs 1 & 4 should be on 1 coil (you have 1 wasted spark because the coil sparks both plugs & one cylinder is on the exhaust stroke) and 2 & 3 on the other. The cylinder from each pair that fires is determined by the fuel injection and the valve timing. I guess what I'm saying is that for a firing sequence of 1, 3, 4, 2 on an engine with no distributor and 2 coils they're wired properly - plugs 1 & 4 come from 1 and 2 & 3 from the other.

If you have a fouling on plugs 3 and 4, I'd suggest you need to look at more than just the ignition system. It could be the fuel delivery where you get too much fuel in those two cylinders because of two faulty injectors, but I think the odds are that you have poor combustion in those two cylinders & would do a compression test to see where you sit - if you have poor pressure on those 2 cylinders doing the test dry, redo it as a wet test(squirt oil into the cylinder prior to checking the pressure), to determine if you have leaky valves or rings.
 
1 - 2 of 2 Posts
Top