Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,
I have been facing the problem since 2 days after having my Battery replaced ( which i replaced wid the same brand n specs with one i had used before ) whereby My transmission has been stuck on 3rd gear. Which i switch it to manual, it shows 3rd gear but when i switch on to acc mode ( before the ignition ) it say 1 which it suppose to be and then when i switch it to N and start, it come back to 3rd gear.
I have checked my transmission oil level which is perfectly fine n is used so far for 9k after my last change.
I have had swap the horn sensor with the atm cont sensor in the sensor console since both sensors ar 12v-20 but issue persist. Tried to reset the battery few times but no luck so far.
I still need to scan the TCM to get the error codes but i have had the similar issue precisely a year ago and as far as i remember, it automatically got fixed in 2 to 3 days time. At the time i did had a scan after the issue was fixed automatically n had the error codes reset n then i had my transmission oil changed too.

Has anyone here faced a similar issue ? Perhaps an insight would be great on this

Thanks
 

·
Banned
Joined
·
7,036 Posts
Need the codes....
 

·
Registered
Joined
·
65 Posts
Regardless of what the indicator says, are you really in 3rd gear?
If you give it gas does it move?
Can you shift any in manual mode?
 

·
Registered
Joined
·
250 Posts
Did you get resolution? My 3.3 got stuck in third around 170k miles. It'd go 1-5 normally unless I idled around 30-40mph then it would jump or drop into 3rd and stay there until I restarted the car. I was hoping it would be electrical or something stupid but multiple places told me I had to replace the trans. (autozone, 3 diff mechanic places). Also my reverse wasn't working (around same time) drove it like this til around 200k... Got a 60k trans put in for 1500$ worth it IMO.
 
1 - 4 of 4 Posts
Top