Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
738 Posts
Discussion Starter #1
So my radio stopped working today....

All I get is "NO SIGNAL" and then it will occasionally get back to normal for a few seconds and back to NO Signal and sometimes after No Signal I get LOADING. Then No signal..

I spent about 30 minutes with the XM folks and they sent a signal to my radio and then a full reset but no good.

The FM / AM works fine and using my phone through the audio works fine.

They told me to check the antenna connection to see if it was loose.

So I have two questions...

How hard is it to get to the XM antenna connection on the radio ?

And is this covered under the Warranty ???

I would like to do it myself if it doesn't involve tearing the whole dash apart but I guess I can wait until Monday and call the dealer but would like some info so I know what I am talking about when I call...

Thanks in advance for any help you can supply.
 

·
Registered
Joined
·
622 Posts
So my radio stopped working today....

All I get is "NO SIGNAL" and then it will occasionally get back to normal for a few seconds and back to NO Signal and sometimes after No Signal I get LOADING. Then No signal..

I spent about 30 minutes with the XM folks and they sent a signal to my radio and then a full reset but no good.

The FM / AM works fine and using my phone through the audio works fine.

They told me to check the antenna connection to see if it was loose.

So I have two questions...

How hard is it to get to the XM antenna connection on the radio ?

And is this covered under the Warranty ???

I would like to do it myself if it doesn't involve tearing the whole dash apart but I guess I can wait until Monday and call the dealer but would like some info so I know what I am talking about when I call...

Thanks in advance for any help you can supply.
Sounds like you need a "shark fin" antenna replaced. Should be under the 5/60 warranty.
 

·
Registered
Joined
·
564 Posts
Audio system is only covered 3/36
 

·
Registered
Joined
·
738 Posts
Discussion Starter #5
Just the head unit is 3/36, I've replaced the shark fins a lot under the 5/60 warranty.
So you think it is the shark fin and not a loose antenna cable at either end ???
 

·
Registered
Joined
·
622 Posts
So you think it is the shark fin and not a loose antenna cable at either end ???
Yup. The antenna cable locks in the back of the radio, and at the shark fin. It shouldn't be loose, but anything is possible I suppose. In my experiences, 9 out of 10 times it's a shark fin malfunction when XM goes out. You can get a "check antenna", or "no signal" message on the radio when it malfunctions.
 

·
Registered
Joined
·
564 Posts
Just the head unit is 3/36, I've replaced the shark fins a lot under the 5/60 warranty.
Good to know. Most would assume the antenna is an extension of the head unit.
 

·
Registered
Joined
·
738 Posts
Discussion Starter #8
Yup. The antenna cable locks in the back of the radio, and at the shark fin. It shouldn't be loose, but anything is possible I suppose. In my experiences, 9 out of 10 times it's a shark fin malfunction when XM goes out. You can get a "check antenna", or "no signal" message on the radio when it malfunctions.
Guess that settles it....

Thanks for your help, I will be calling my dealer on Monday for an appointment ..
 
1 - 8 of 8 Posts
Top