Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi guys,
The red seatbelt indicator is staying on after I've put my seatbelt on. Then once i set off it starts flashing adn making a beeping noise for a couple of minutes before stopping, then continuing to flash. I think it's something to do with the seatbelt anchor part as when it started doing it originally if I wiggled the part that the belt slots into the indicator would go off. Now no matter what I do it flashes. I've checked the visible wiring under the seat and it's all firmly connected. Is there anything else I can do? The seatbelt itself still works - yank on it and it locks, so I'm guessing a sensor has stopped workign somewhere! Wouldn't mind but I've got two dogs and the next time they get in the car with that beeping noise it's going to be mental!!!

Anyone got any idea's how to stop this? Many thanks in advance! :thumbsup:
 

·
Registered
Joined
·
3 Posts
To be fair it could be anything i think ur best option would be to test all the wires also the wires that connect it under the dash i also believe tht sumtimes a fuse can affect this i had this problem i replaced the fuse and then bang it wasnt there anymore.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks,

I found a weird black and silver button under the right hand side of dash, just above where my right shin is when foots on the accelerator - I'm sure my mom and dad's doesn't have that. Anyway I pressed it whilst stationary and there was a click & the seatbelt light stopped flashing. That lasted about a day & then last night it started again - pressing that little button didn't help this time.

So I'll be checking that fuse box next - I've had a quick look over it once before - some of writing on the fuses is upside down - daft question next but I'm guessing that doesn't really matter as they're only strips of wire?

Oh and I don't know if it makes any difference but I've got remote central locking that's apparently aftermarket - and it stopped working summer last year. For about two days last week when the weather was really hot, it worked when you used the key in the drivers door.. Now it just doesn't. I can't really afford an electrician to look at it so suffering with manual door opening
 
1 - 4 of 4 Posts
Top