Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hi
when i turn on a/c the blower give me warm air no cold when i connect battery to a/c relay every thing is perfect the compresor workd and the air is cold .

note when i turn on a/c the fans on radiator worked . and i try another ac panel and i still have the same problem
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,318 Posts
Have you checked the "A/CON" fuse on the engine bay fusebox?
Have you checked the power supplies to the A/CON relay?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3 (Edited)
a/con fuse yes its work
but how checked the power supplies to the a/con relay
i try replace the a/con relay with another but no thing work
when connect battary direct to a/c relay place then the compresor workd excelant
is some thing disconnect the power supplies to the a/con relay.
i checked on the computer and give me errore code b1257
i checked this error on the internet and give me aqs sensor and tried another also the same problem and changed the A/C CONTROL UNIT still same problem
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
a/con fuse yes its work
but how checked the power supplies to the a/con relay
i try replace the a/con relay with another but the same problem
when connect battery direct to a/c relay place then the compressor worked excellent
is some thing disconnect the power supplies to the a/con relay or sensor give command to disable the compressor
i checked on the computer and give me errore code b1257
i checked this error on the internet and give me aqs sensor and tried another also the same problem and changed the A/C CONTROL UNIT still same problem.
when i click on a/c just A/C Condenser Fan work and the blower worked .the compressor not work.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
sorry i forget to tell you that some times when click on ac its work and the air is cold and every thing is perfect but if click again to turn off then click to turn on the problem back (warm air)
 

·
Registered
Joined
·
163 Posts
Bad relay, bad/loose relay socket, bad wiring, a faulty sensor telling it to keep the AC off (like a bad evaporator temperature sensor for example).

Get the diagrams and trace the circuits involved.
Have you checked for voltage at the relay socket?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
And which sensor is possible to stop the compressor . And if i replace sensor is it need to programing on the computer
 
1 - 8 of 8 Posts
Top