Hyundai Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
2 years in and my i10 seems to Rev up when changing down gears only 300/400 up, but never when changing up. Generally when going from 3rd to 2nd as it is only when slowing down I do not think it is worth a trip to dealers to ask for software update. Seems to also do now and again when coming to a stop and pressing the clutch to go into neutral.

Not sure if always done was listening for another noise without stereo on and noticed!

Anyone else's only rev up when changing down gears?

Thanks
 

·
Registered
Joined
·
182 Posts
2 years in and my i10 seems to Rev up when changing down gears only 300/400 up, but never when changing up. Generally when going from 3rd to 2nd as it is only when slowing down I do not think it is worth a trip to dealers to ask for software update. Seems to also do now and again when coming to a stop and pressing the clutch to go into neutral.

Not sure if always done was listening for another noise without stereo on and noticed!

Anyone else's only rev up when changing down gears?

Thanks
surely an element of increased rpm's when changing down is normal but the other bits you mention may not be normal
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
That is what I thought about it being normal. It never revs up when changing up. It is just when slowing down like I said when say in second and you slip into neutral as you come to stop. So do other i10s do that or is there zero rev up after ecu download ?

Thanks again
 

·
Registered
Joined
·
50 Posts
My three year old i10 was doing the same thing, I took it in last week for an update and it hasn't done it since, it feels so much better to drive, definitely worth doing,
 

·
Registered
Joined
·
50 Posts
Yes, it was really strange, it also needed a lot of revs in 1st gear or it stalled, both problems were sorted out with the update, it's worth a try. I think there was another thread about the same problem further back.
 

·
Registered
Joined
·
98 Posts
That is what I thought about it being normal. It never revs up when changing up. It is just when slowing down like I said when say in second and you slip into neutral as you come to stop. So do other i10s do that or is there zero rev up after ecu download ?

Thanks again
My 59 plate i10 classic does the same,
looks like a trip to the dealers, when I get the time.
 

·
Registered
Joined
·
245 Posts
Just checked a 59 and 10 plate i10 1.2 and none of them exhibit the rev issue ?

If you want me to try anything else let me know.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #11 ·
Cheers for checking.

Gario is yours only when changing down?

I do 70 mile journey per day and it doe sit about three times, so not much and only when slowing.

Does the rev up thing damage the clutch in anyway, does anyone know?
 

·
Registered
Joined
·
98 Posts
Cheers for checking.

Gario is yours only when changing down?

I do 70 mile journey per day and it doe sit about three times, so not much and only when slowing.

Does the rev up thing damage the clutch in anyway, does anyone know?
Yes its only when slowing down.

I cant help with the question regarding the clutch.

Gary.
 
1 - 13 of 13 Posts
Top