Hyundai Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I posted about the transmission issues I had. Had a replacement put in. The lights come on, it clicks, doesn’t start though.
checked grounds, check the connectors removed in the process, nothing. Starter doesn’t engage. Checked that the shift selector was correct, fine. The car knows it’s in d and displays the put car in park or neutral to start message. Is the gear window on the dash supposed to light up P when the ignition is turned on or does it not show until the car is running?
 

·
Registered
Joined
·
1,554 Posts
Turn the crankshaft with a breaker bar. Possibly the converter didn't seat on the input shaft? If the engine won't spin from the bolt on the damper pulley, it's time to start checking the work.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Turn the crankshaft with a breaker bar. Possibly the converter didn't seat on the input shaft? If the engine won't spin from the bolt on the damper pulley, it's time to start checking the work.
I will definitely try that in the morning! I was going to check around the starter as well.
 

·
Registered
Joined
·
1,554 Posts
I wonder if that dreadful plastic starter fork snapped and the click you hear is the solenoid but no engagement because the starter gear is never moved into place to spin the flexplate.
 

·
Registered
2007 Honda CRV
Joined
·
4,396 Posts
First is to check all fuses

Starter relay by-pass test
That will tell you whether the issue is in load side or control side.

Or check starter relay socket for voltages and grounds while ignition is in cranking mode
Two should be 12 volts and two should be ground
Can try swapping relays??

Usually replacing transmission, the gear selector (park/neutral safety switch)
will need to be aligned correctly
or the park/neutral safety switch will not work and prevent starting engine
 

·
Registered
Joined
·
22 Posts
Discussion Starter #12
I turned the crankshaft. I moved rather freely. Checked all connections I could easily get to.
when in park, it acts like i described. Putting into neutral, it tells me to put in park or neutral. I may be onto something?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #14
First is to check all fuses

Starter relay by-pass test
That will tell you whether the issue is in load side or control side.

Or check starter relay socket for voltages and grounds while ignition is in cranking mode
Two should be 12 volts and two should be ground
Can try swapping relays??

Usually replacing transmission, the gear selector (park/neutral safety switch)
will need to be aligned correctly
or the park/neutral safety switch will not work and prevent starting engine
I’m going to try to move it a bit. When in neutral, the guide hole was aligned. But If I try to start in neutral, it says to put in park or neutral.
 

·
Registered
Joined
·
1,460 Posts
I don't know the car. The inhibitor switch harness, is that seated correctly? Do all other positions register correctly? Seems strange it's not seeing N or P unless there's an issue in the switch itself. SO what is this 2.0, 6 speed auto?
 
1 - 20 of 38 Posts
Top