Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2013 Sonata - Hello all. I have this problem, when I start the car all sees normal, but when I put the shifter in D the gear indicator keeps in P but in a few seconds the P disappears and don't show any letter, so when i return the shifter to P it appears again. Sometimes doesn't appear and i cant move the shifter, so i have to turn of the car and then back on and the P re-appears, but do the same.

Note: If i drive the car without the gear indicator mark the D letter, the car feels heavy.

Any clue what's going on?

460147
460148
 

·
Registered
Joined
·
1,130 Posts

and

 

·
Registered
Joined
·
1,002 Posts
2013 Sonata - Hello all. I have this problem, when I start the car all sees normal, but when I put the shifter in D the gear indicator keeps in P but in a few seconds the P disappears and don't show any letter, so when i return the shifter to P it appears again. Sometimes doesn't appear and i cant move the shifter, so i have to turn of the car and then back on and the P re-appears, but do the same.

Note: If i drive the car without the gear indicator mark the D letter, the car feels heavy.

Any clue what's going on?

View attachment 460147 View attachment 460148
That's the inhibitor switch that's located under the battery and connected to the transmission. It's a very simple fix.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top