Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Okay, so i read all the threads in here concerning the matter and multiple of other places. I bought a Hyundai Accent 1.5 GLS 1996 cheap, runs fine - but overdrive is malfunctioning, the car just runs into neutral when i turn overdrive on and reach the designated speed.

- we have just changed the gearbox oil and filter, runs now without any jerks atleast - well, thats a small win so far! hopefully a new tranny is not needed :) But the overdrive issue is still present - i have dismantled the plastic coverings around the gear knob, and been looking for any broken wires - i dont have a voltmeter to check for plasticwire-internal non-visuable brokings.

My question is - SHOULD a broken connection between the overdrive button around the gearlever cause the engine to go into neutral? It seems that most people on the forum when they push overdrive nothing happens, they dont mention the tranny going into neutral - is it just implied on each thread or am i one of the few that gets the neutral issue and is it something else than just broken wires?

Thanks in advance - ill keep you posted

Mike
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
- I took a look at the overdrive switch, no broken connections there - took a test drive, still no overdrive

- the springer went missing down the shaft in the plastic surrounding it, great - now im forced not to accidently touch the O/D button..
 

·
Registered
Joined
·
210 Posts
The wiring to the overdrive button on my accent was broken within the wire covering. It was intermittently connecting and disconnecting the overdrive circuit causing a 'bucking' feeling while driving because the OD was engaging and disengaging. The light was not turning on and off, that wire was still good.

For the car going into neutral, perhaps it is in the gear selector assembly itself.

If you look at the HMAservice site there is a cable adjustment for the gear selector.
 
1 - 3 of 3 Posts
Top