Hyundai Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I bought a 04' Santa Fe about a month ago and recently it's doing a strange and annoying thing. Everytime I start up the car and shift gears from "P" to "D" and I start to accelerate it makes this 2 huge thumps and the car kinda chokes, but after that... everythings fine. Any idea what the problem is?
 

·
Registered
Joined
·
12 Posts
Originally posted by SantaFe04@Oct 27 2004, 04:10 PM
I bought a 04' Santa Fe about a month ago and recently it's doing a strange and annoying thing. Everytime I start up the car and shift gears from "P" to "D" and I start to accelerate it makes this 2 huge thumps and the car kinda chokes, but after that... everythings fine. Any idea what the problem is?
[snapback]2077[/snapback]​

Take it to the dealer, lets see if they stand behind the car... PDT
 

·
Registered
Joined
·
2 Posts
Originally posted by SantaFe04@Oct 27 2004, 08:10 PM
I bought a 04' Santa Fe about a month ago and recently it's doing a strange and annoying thing. Everytime I start up the car and shift gears from "P" to "D" and I start to accelerate it makes this 2 huge thumps and the car kinda chokes, but after that... everythings fine. Any idea what the problem is?
[snapback]2077[/snapback]​


I bought my '04 Santa Fe GLS 6 cylinder in Sept. and I'm scheduled for my first maintenance (3500 miles) tomorrow. I'm having the same problem! I get the "choking" going from reverse to drive and even sometimes when accelerating after a light. I'm a little concerned because when I spoke with the service rep on the phone today and explained the symptoms, he indicated it was "normal"! But he said they'd look into it. I'll be back to you after my service to see if the problem was taken care of.
 

·
Registered
Joined
·
2 Posts
Originally posted by duke@Dec 23 2004, 10:34 AM
are your S-F's have a 2.7ltr or 3.5 ltr V6 engine???
[snapback]3979[/snapback]​


Sorry it took so long to get back to you. My computer was down. I'm not sure....
2.7 or 3.5 litre, but I took it to the dealer and they "reprogrammed" the transmission computer supposedly. The problem seems to be solved.

So far I'm very happy with the Santa Fe.

Sharon
 

·
Registered
Joined
·
9 Posts
Originally posted by coraltree@Jan 13 2005, 05:08 PM
Sorry it took so long to get back to you. My computer was down. I'm not sure....
2.7 or 3.5 litre, but I took it to the dealer and they "reprogrammed" the transmission computer supposedly. The problem seems to be solved.

So far I'm very happy with the Santa Fe.

Sharon
[snapback]4826[/snapback]​


Sharon,
Just look at the rear hatch. The 3.5's have a badge that say 3.5L. The 2.7's (like mine) just say V6.

Chuck
 

·
Registered
Joined
·
1 Posts
Originally posted by SantaFe04@Oct 27 2004, 05:10 PM
I bought a 04' Santa Fe about a month ago and recently it's doing a strange and annoying thing. Everytime I start up the car and shift gears from "P" to "D" and I start to accelerate it makes this 2 huge thumps and the car kinda chokes, but after that... everythings fine. Any idea what the problem is?
[snapback]2077[/snapback]​



I bought a Santa Fe on Nov. 19, 2004. Just about Christmas time I noticeda "jumping" sensation just after start up , upon accelerating. It seemed to 'go away' after it warmed up. Just last week I noticed a huge oil spot under it. I had someone check my oil and sure enough it was dry! I took it to an auto parts store and got oil in it. I got it into the dealership the next morning. They told me it was a broken head gasket!! PLEASE have your oil checked... if you have a similar problem you could blow your engine...
C :(
 

·
Registered
Joined
·
243 Posts
There is a TSB out on the Hyundai USA Webtech site that describes this problem. Take it in to the dealership and they will perform the necessary fix for it.

TS out
 
1 - 9 of 9 Posts
Top