Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,

2006 Azera Limited. Powered passenger seat has two switches. Move whole seat forward/back, and recline forward/back. All working except the move whole seat back. Seat moves forward and now does not move back.

I hear reports about the switches going bad, so I pulled the cover off the switch and pulled the switch off. I do not know which pins to jump to test if it's the switch or another issue.

I also look up ordering a new switch, and for my make/model it's showing me a vastly different item(has 3 positions for memory).

Any help here would be greatly appreciated. Can post photos if needed tomorrow when it is light out.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
This is the switch RockAuto and MANY other sites are showing me match, not even close:

from RockAuto: /en/catalog/hyundai,2006,azera,3.8l+v6,1433291,electrical-switch+&+relay,power+seat+switch,4612

Incorrect item for me. Also had to goof with the URL since I am new...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
This looks a LOT more like it, again I goofed with the URL sorry if this is prohibited...

From FourGreen /store/scripts/SWITCH-ASSEMBLY-POWER-SEAT-RIGHT-SIDE-p-882953L100K7
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Pulled the switch apart from its housing, down to the circuit board. On here is printed:
DMT(TG-CAR)
FR PWR SEAT S/W(LHD 4WAY)
 

·
Premium Member
Joined
·
875 Posts
Hello,

2006 Azera Limited. Powered passenger seat has two switches. Move whole seat forward/back, and recline forward/back. All working except the move whole seat back. Seat moves forward and now does not move back.

I hear reports about the switches going bad, so I pulled the cover off the switch and pulled the switch off. I do not know which pins to jump to test if it's the switch or another issue.

I also look up ordering a new switch, and for my make/model it's showing me a vastly different item(has 3 positions for memory).

Any help here would be greatly appreciated. Can post photos if needed tomorrow when it is light out.
Check both slide motor switch(with connector S20) and slide motor limit switch(with connector S28).
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Hey thanks for the reply. Last night I had to pick up a friend and was a little impatient, so I pulled the switch apart down to the circuit board and actual switches... Lo and behold it worked when connected. So it was the switch/switch housing having an issue.
 
1 - 6 of 6 Posts
Top