Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
2012 accent GLS hatchback - 126,000 miles only issue so far was bad 02 sensor 4 moths ago.

Don't know if there are 2 knock sensors but I am getting PO326 DTC on my Innova 299 dollars reader.

Recently after 2 weeks of resetting the PO326 Knock sensor 1 sensor range/performance bank 1 DTC I am now getting a bucking, hesitation, almost like when my EGR went out on my truck. The Malfunction Indicator Light or check engine light has not come back on but the code is still set after I cleared it?

I shifted into manual shifting and it does it quite a bit less than automatic shifting but still some nonetheless. When I shift out of manual electric shifting into automatic it seems like it lugs down when it goes to higher gears?

My wife had just put gas into it and 35 minutes later on our way to the VFW it started the bucking/hesitation and I am wondering if the computer is retarding the timing causing the hesitation. I used Lucas Fuel Injector cleaner and HEET to get rid of any moisture in the tank and still does it - I have been using fuel injector cleaner regular - yes up to 10% alcohol 87.

Trying to locate it - must be underside back of block and I saw a picture that looked like near the starter but these **** transverse crap engines are stuffed so tight I cannot hardly see anything? It could be loose? or more like could be bad as there are no vibrations?


I will jack it up tomorrow on my low profile ramps but didn't want to waste time looking in the wrong place?


Looks round black doughnut with 12mm or so bolt through and the 2 wire connector with single loom to connector from what I gathered?

anybody know how to get to bank one and two I was going to swap them and see if the code swaps to bank 2 or swap the leads (make jumper wire to cross outputs to opposite sides) and send signals to opposing sensors since there are only two wires?


I would also love to compare resistance for the two and see if there is anything glaring wrong but some of these output millivolts so its hard to tell. If bank one reads 4 ohms and bank 2 that works reads 8 ohms and swapping swaps the problem then I guess 8 ohms is where it should be -- of course the bolt could be loose on bank 1 and done?


Any help on locating bank 1 and 2 - I did see something under the injectors (on the front side) bolted to the block with a 2 pin connector on it but it had no wire loom and the bolt wasn't through the center?


Thanks for any help in advance!


I was a previous Navy aircraft electrician so I like to understand vice just changing out parts using the shotgun method with shells all over the place and nothing fixed.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,283 Posts
Looks round black doughnut with 12mm or so bolt through and the 2 wire connector with single loom to connector from what I gathered?
Yup.

rborges66 said:
anybody know how to get to bank one and two I was going to swap them and see if the code swaps to bank 2
Your engine only has one bank of cylinders, so only one sensor.

2013 Hyundia Accent - P0326
 

·
Registered
Joined
·
17,552 Posts
Description:

This bulletin provides information related to an ECM (Engine Control Module) software update for certain 2012~2013MY ACCENT(RB) and VELOSTER(FS) 1.6L GDI vehicles that may experience either of the following:

 Check engine light for DTC P0326 - Knock Sensor 1 Circuit Range/Performance (Bank 1),

or

 Spark knock noise on heavy acceleration in warm ambient temperatures,

or

 Check engine light for DTC P0441 - Canister Purge Valve (CPV) - Incorrect CPV Flow

355 -- RB 1.6GDI ENGINE DTC(P0326/P0441) IMPROVEMENT

BUT,,,,,, they should install 429, as it is the latest version software that supercede previous updates

429 -- RB 1.6GDI PCSV MIL LAMP ON(P0441) IMPROVEMENT
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Thanks, just figured there was 2? I have never owned anything that didn't have spark plugs, wires and one coil so this transverse jammed engine and many components that I have never seen or know little about is sluggish for me.
 

·
Registered
Joined
·
17,552 Posts
Thanks, just figured there was 2? I have never owned anything that didn't have spark plugs, wires and one coil so this transverse jammed engine and many components that I have never seen or know little about is sluggish for me.
Better look again..

1 line on a 4 cylinder is Bank 1

You do have 4 spark plugs -- NGK Iridium is what installed,, 100,000 service

You do have 4 coils, 1 on top of each plug,, no spark plug wire
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
2005 wrangler unlimited Rubicon - I forgot my 2004 Silverado has the stupid coil packs above the spark plugs on the valve cover and then run a short spark plug wire from the pack to the spark plug in the head. So they added 7 more coil packs, kept the spark plug wires (only 5 inches) and left the spark plugs in the heads the same place - I

When you don't own foreign, transverse, stuffed engine compartments until 2013 and never changed them - you have never dealt with these 80.00 x 4 coil packs that sit over the sparkplug - I though they may have been injectors, yeah?

Only American rear wheel drive straight transmissions, drivelines and transfer cases - even my 1996 cavalier (with transverse engine) had one coil but I couldn't reach behind the motor to get the oil filter out because my arm is too big and I had to access from the bottom after removing the exhaust connections.


When I removed the plugs (after my 20th century mechanic hands and eyes found the could packs that I thought were injectors) the holes were clean, no cover leaks, and each had build up - I wire wheel the build up, sand blasted in my early 20th century spark plug cleaner and then gapped them properly because 3 weren't even close to .040 and cupped on the tang from electrical erosion of 126,000 miles and all is fine.


Waiting on Bosch double iridium coated 7 year performance guarantee plugs. I sent to the dealer several times and they either didn't ask if I wanted the 100,000 maintenance done or said they did and charged us for them? 1/16th of an inch deep cupping 1/8 long in the tang - electrodes looked fine. Worx like new.
 
1 - 7 of 7 Posts
Top