Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
So my car is a 2013 sonata 2l turbo i have had it about 4000kms so far. I installed a torcon sound plate today and instead of hearing the woosh when i let off the gas peddle i hear a constant air rushing while i am on gas and wide open throttle and when i let off the gas i hear nothing. This should be the opposite i should hear nothing at wot and a woosh when i let off gas peddle. I have a new bypass valve coming and going to try a new electronic boost controller thats under bypass valvr yet if needed. Is it possible a vacuum line is in wrong location. Maybe wastegate voltage. Any ideas here would be great before i take it to dealer that i dont have time for.
 

·
Registered
Joined
·
937 Posts
It's possible, take pictures and we'll help the best we can. Take pics of the adapter from the top and from the side, take pics of your bov solenoid as well.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Everything appears to be stock other then torcon bov sound platw that gets installed behind the bypass diverter valve. it wont let me post a link and dont no how to add pics
 

·
Registered
Joined
·
937 Posts
Just drag them into the window below where you type.

I'm guessing you don't have the O ring that seals the bov adapter or you have it upside down.

Please verify you have the 2 o-rings on the adapter face down onto the stock flange like the picture below.

bov plate.jpg
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
I think it may be caused by my bypass valve the one clip that holds the spring in it is broke only thing i can think of at the moment both orings are installed and it is in proper position way it lines up i do havr a new bypasd diverter valve coming ordered monday so should show up tomorrow morning i hope car quest delivery driver shows up
 
1 - 8 of 8 Posts
Top