Hyundai Forums banner
21 - 27 of 27 Posts

·
Registered
Joined
·
17,548 Posts
So, I replaced the sensor, 350 miles later the check engine came back on. It is still giving me the P0150 code. I'm taking the car to the dealer for an ECU update, they will charge $135 for an hour of labor. Hopefully this will clear up the check engine light...I will keep you posted.
2.7L ECM UPDATE - MIL ON WITH DTC P0130/P0150

DESCRIPTION:

This bulletin provides information related to the ECM software update of some 2005-2006MY TUCSON (JM), SANTA FE (SM) or TIBURON (GK) vehicles with 2.7L engines that experience a malfunction indicator lamp illuminated with either of the following ECM (Electronic Control Module) related DTC:

- P0130: O2 Sensor Circuit Malfunction (Bank1/ Sensor 1)
- P0150: O2 Sensor Circuit Malfunction (Bank2/ Sensor 1)

NOTE: This ECM reflash does not require oxygen sensor replacement.

Models: 2005-2006MY TUCSON (JM), SANTA FE (SM), TIBURON (GK) vehicles
with 2.7L engines.

Affected Vehicle Production Date Range: All
 
  • Like
Reactions: [email protected]

·
Registered
Joined
·
6 Posts
2.7L ECM UPDATE - MIL ON WITH DTC P0130/P0150

DESCRIPTION:

This bulletin provides information related to the ECM software update of some 2005-2006MY TUCSON (JM), SANTA FE (SM) or TIBURON (GK) vehicles with 2.7L engines that experience a malfunction indicator lamp illuminated with either of the following ECM (Electronic Control Module) related DTC:

- P0130: O2 Sensor Circuit Malfunction (Bank1/ Sensor 1)
- P0150: O2 Sensor Circuit Malfunction (Bank2/ Sensor 1)

NOTE: This ECM reflash does not require oxygen sensor replacement.

Models: 2005-2006MY TUCSON (JM), SANTA FE (SM), TIBURON (GK) vehicles
with 2.7L engines.

Affected Vehicle Production Date Range: All
I'm running out of options here. I took my Tucson to the dealer, 10 miles before arriving the check engine light turned off by itself. Anyways, I asked them to update the ECM with their latest software per the Service Bulletin. They did. 20 miles after this was completed, check engine turns on. I got home and cleaned the connector contacts and as of this morning it is still on. Any other possible causes for P0150?
 

·
Registered
Joined
·
206 Posts
Which O2 sensor did you install? I changed both my S1 sensors in my 05 Sportage with the 2.7 when I got it and chased my tail with those codes for 3 months only to find out that the supposedly compatible Boschs I installed were not compatible. I installed NTKs and the codes and drivability issues went away.
 

·
Registered
Joined
·
6 Posts
Which O2 sensor did you install? I changed both my S1 sensors in my 05 Sportage with the 2.7 when I got it and chased my tail with those codes for 3 months only to find out that the supposedly compatible Boschs I installed were not compatible. I installed NTKs and the codes and drivability issues went away.
I replaced the O2 sensor in Bank 2 Sensor 1, I used Bosch.


So a quick update, my check engine light turns On/Off by itself every 50-100 miles...not sure what to do next. The car runs great, I don't notice anything wrong with it. I might give it a shot on those NTKs sensors...
 

·
Registered
Joined
·
6 Posts
Which O2 sensor did you install? I changed both my S1 sensors in my 05 Sportage with the 2.7 when I got it and chased my tail with those codes for 3 months only to find out that the supposedly compatible Boschs I installed were not compatible. I installed NTKs and the codes and drivability issues went away.
I replaced the O2 sensor in Bank 2 Sensor 1, I used Bosch.


So a quick update, my check engine light turns On/Off by itself every 50-100 miles...not sure what to do next. The car runs great, I don't notice anything wrong with it. I might give it a shot on those NTKs sensors...
 
21 - 27 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top