Hyundai Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
My wifes accent acted up a couple of weeks ago, said it wouldn't shift anymore, so she get home and get other car.
Evenings i picked up accent and it drove fine.
Next day i drove to work and same thing, as soon it'll go in overdrive, engine revs' up and it feel like it shifted to neutral.
Switch OD off and finds 3rd gear with no probs!
Leave OD off shifts fine first through third gear!
Took it to the shop Tranny flush and filter but didn't help.
Without speculating, has someone an idea, is it the (end clutch/Overdrive) i don't want to spent too much, otherwise that darn thing goes into the crusher(lol).
I took it also to a Transmissionguy and he told me " a min of $1500 or more(shiver)"

thanks for any advise or help
 

·
Registered
Joined
·
17,552 Posts
Kinda simple repair....

First thing, hook up HI-SCAN or GDS, get into the transmission control module, then current data, and sse if the TCM recognizes the OD switch to be "ON" or "OFF" as switch actuated on the shifter..

Common problem is the wiring breaks at bottom of the shifter post from movement over time... I not replaced 1 in a long time, but if you, you can adjust/re-route the loop at bottom to reduce the flex of the tiny harness some
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
switch works fine, that was my first thought though......
If i drive about 70mph and push overdrive button engine revs up(like neutral) push it again, goes back to third gear!
Now the question??? What is the problem exactly.
Like i wrote earlier i don't wanna drop $1500 or more into it, so any advice would be really appreciated!

tried some lucas additive, made things worse! Wont find first gear anymore*grrrr"
seems like stuck in second . Will shift in 3rd though.

*headscratch* anybody any thoughts?
 

·
Registered
Joined
·
4,851 Posts
I had a Mitsubishi like that once. I just drove it in 3rd for a year... until I got rear ended.

The short answer is: Accents have weak transmissions. I suspect the bearing between 3rd and 4th is smashed. Drop the pan and look for metal.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
i like that answer!!!
think positive*rofl*
will drop pan and inspect! So you also think its more likely a gear or bearing/clutch or something like it?
I looked at the schematic for the hydraulik but didn't make much sense to me!
thank you very much!
 

·
Registered
Joined
·
17,552 Posts
QUOTE (achim59 @ Jul 25 2010, 11:27 AM) index.php?act=findpost&pid=344549
switch works fine, that was my first thought though......
If i drive about 70mph and push overdrive button engine revs up(like neutral) push it again, goes back to third gear!
Now the question??? What is the problem exactly.
Like i wrote earlier i don't wanna drop $1500 or more into it, so any advice would be really appreciated!

tried some lucas additive, made things worse! Wont find first gear anymore*grrrr"
seems like stuck in second . Will shift in 3rd though.

*headscratch* anybody any thoughts?

Now you have added some more detail... I would lean on possible loss of oil pressure to the 4 gera pack, likely due to seal or the TORRINGTON style roller bearing come apart and laying in oil pan in pieces..
 

·
Registered
Joined
·
4,851 Posts
QUOTE (achim59 @ Jul 25 2010, 01:01 PM) index.php?act=findpost&pid=344571
i like that answer!!!
think positive*rofl*
will drop pan and inspect! So you also think its more likely a gear or bearing/clutch or something like it?
I looked at the schematic for the hydraulik but didn't make much sense to me!
thank you very much!
That's just my guess. If the bearing is smashed, then others have said it is possible to replace it without too much hassle, but what do I know, I never looked at one.

What SBR says is probably more likely, and I'd listen to him since he is a professional Hyundai mechanic. But those guys don't like to open transmissions anymore to replace bearings, they simply replace as a unit. So look for the broken wire first.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
so, drop the pan is the thing to do.....
thx keep you guys posted, but it wont be done till next weekend or so, waaaaayyyy to busy and luckily have another car! :p
to sbr Od light on dashboard comes on and off with every push so i don't think its the switch!
but who knows may be another gremlin .....
 

·
Registered
Joined
·
17,552 Posts
QUOTE (achim59 @ Jul 25 2010, 09:57 PM) index.php?act=findpost&pid=344720
to sbr Od light on dashboard comes on and off with every push so i don't think its the switch!

There is 3 wire on that switch... 1 input, 2 output

1 - power from fuse block with key on to switch

2 - OD light is 1 line, switch for OD off just sends power to the yellow light to illuminate it, no power to TCM for OD signal

3 - other wire goes from swith to the TCM (OD off switch signal input).... like I said before, possible broken wire at bottom of shifter, TCM not get power from other side of switch....
 

·
Registered
Joined
·
18 Posts
Discussion Starter #10
QUOTE (sbr711 @ Jul 25 2010, 09:02 PM) index.php?act=findpost&pid=344731
There is 3 wire on that switch... 1 input, 2 output

1 - power from fuse block with key on to switch

2 - OD light is 1 line, switch for OD off just sends power to the yellow light to illuminate it, no power to TCM for OD signal

3 - other wire goes from swith to the TCM (OD off switch signal input).... like I said before, possible broken wire at bottom of shifter, TCM not get power from other side of switch....
thanks, i'll try but i still think nothing's wrong with the switch. It illuminate the OD-light on the dashboard and tranny acts like trying to shift ....anather push OD-light comes off and tranny shifts back in third gear!
but i'll check again
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
news on tranny.......
after reading a bit @ hmservice i thought"well no Mil -light doesn't mean no code!"
So i went out and checked! It has an code and its P0734[ fourth gear system malfunction]
• Check the pulse generator A and pulse generator B connector
• Kickdown brake slippage
• Check the end clutch or control system
• Check the pulse generator wiring harness

now it looks a lil' different......
the question is now, whats the easiest to check of the list???????????

:innocent:
 

·
Registered
Joined
·
25 Posts
Your problem is without a doubt the overdrive (end clutch) bearing has exploded. Drop your pan and you will find little pins (ie the exploded needle bearing) The good news is that you can replace it while keeping the tranny in the car. See my other posts and you will find pictures and part #s You will prob only need the bearing, 4 qts fluid, and a new filter.
 
1 - 12 of 12 Posts
Top