Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've recently discovered that my oil pressure sensor is bad and oil is pouring from the bottom of the engine every time it runs. I've got the part but I cannot find a video, picture or manual that shows the location of the sensor. I've seen some videos for the 2011 santa fe that show the sensor in the engine valley under the intake manifold but nothing for my current model. If anyone can provide some insight it would be greatly appreciated!

2013 Hyundai Santa Fe GLS 2WD 3.3L DOHC V6
 

·
Registered
Joined
·
138 Posts
If the leak is as bad as you say, can't you follow the trail upwards to see where it's coming from? Take all the various engine covers off for a better view.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
14,371 Posts
I found this photo when I did a quick google search. It's from an earlier engine than yours but it's not where the sensor was in the video you mentioned so thought it would be worth a look.

 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I was able to locate the sensor today. After 4 hours of tearing the top of the block apart we found it in the valley of the block. We had to take out the air box/components, battery, manifold (all the plugs too) and the fuel injectors to finally expose it. Unfortunately the sensor is tucked tight on the passenger side of the valley right next to a coolant line which made extraction exceedingly difficult. Used a 23mm wrench to very slowly (no room to get full rotations, maybe a 1/4 turn per twist) extract the part. Valley was loaded with oil and took a bit to clean. Assembly was about 2 hours and make sure to prime the fuel injectors before starting by turning the car on (don't start) then off, on etc. We did it 5 times before firing the engine and it started right up. Light was off and car ran great!

This is not for a novice, you definitely need someone with mechanic experience to help. I posted a video online if anyone wants to check it out. I didn't go over the finer details, just the main points and the location.

Thanks for all the help!
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
14,371 Posts
I am looking for the one on a 2009?
You should probably start a thread on the 2009 forum in that case, and tell us what engine we're working with when you get there.

If I helped you fix it, why not...

Your support is greatly appreciated
 
1 - 7 of 7 Posts
Top