Hyundai Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Checking if anyone else has seen this problem. On the trip meters (10.25) for the Since Refueling trip meter which when set should only reset after refueling or when manually reset has now intermittently started to reset on its own in-between refueling. This seems to happen on vehicle start.

I also noticed the last time that the LCD mode was on the driver assist menu instead of the trip computer which is usually my default mode.
 

·
Registered
Joined
·
82 Posts
I noticed this once and I attributed it to the fact the car wasn’t used for 4 or 5 days. It never happened again but I believe it’s a software glitch.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
91 Posts
I noticed this once and I attributed it to the fact the car wasn’t used for 4 or 5 days. It never happened again but I believe it’s a software glitch.


Sent from my iPhone using Tapatalk
Same happened to me. We took our 2021 Palisade on vacation and when I came back and got in my Tucson Hybrid to go to work the trip odometer had reset by itself. Not sure why but sitting for a few days seems to cause this issue.
 
  • Like
Reactions: djasonw

·
Registered
2022 Tucson Hybrid Blue trim
Joined
·
264 Posts
I think lots of nx4 owners have experienced this, including myself. It's a problem with the analog and digital gauges. I have noted the random reset many times and it does not follow long periods of disuse. It can reset after only a short shutdown. Needless to say, a trip meter that randomly resets is useless. Fortunately the accumulated miles trip meter is reliable but I sure would like to have the "since refueling" meter work as advertised. I suggest you open a ticket with the dealer as I did. No. They won't be able to duplicate, much less solve the problem, but the problem gets reported to Hyundai nonetheless and squeaky wheels get the grease.
 

·
Registered
2022 Tucson Hybrid Limited USA Market, Amazon Grey/Black With full OEM Spare
Joined
·
260 Posts
Randomly, and it is horrible. My 2011 Elantra and 2021 Kona work as advertised since day one.

It's not a new feature and they could care less as they can't make the cars fast enough.
 

·
Registered
2022 Tucson Hybrid Blue trim
Joined
·
264 Posts
Randomly, and it is horrible. My 2011 Elantra and 2021 Kona work as advertised since day one.

It's not a new feature and they could care less as they can't make the cars fast enough.
Have you complained to your dealer about the problem? Open a trouble ticket with your dealer even if they won't be able to duplicate the problem. This way Hyundai knows there are a lot of customers out there that would like to have the problem fixed and the dealer can notify you when a fix is available.
 

·
Registered
2022 Tucson Hybrid Limited USA Market, Amazon Grey/Black With full OEM Spare
Joined
·
260 Posts
Updated firmware solved no problem, but did remove the favorites icon.[regression imo]
 

·
Registered
Joined
·
91 Posts
Mine did the 'normal' reset just now. I've got the latest firmware in it, so that's not cured anything. However, I did notice one difference. Normally, I have my Android phone plugged in and I unplug it and remove it before locking the car. This time, I left the phone plugged in and locked it all up. Came back, and it had reset itself.

So, I will continue to play - but it's one point on a graph.

Alan
 

·
Registered
Joined
·
91 Posts
Mine did it twice today. First time when I started the car after it being sat there for a week (I'd been on holiday). I then drove it to the garage (1.5 miles) to fill up, which reset it as normal). I then drove it another 4 miles and stopped. When I restarted it after an hour, it had reset again.

I will inform my dealer of this issue, but I don't think there's anything they can do - I think it's a Hyundai problem which needs a firmware update.

Oh - it also turned my Android Auto off as I was playing an MP3 file. No idea why. My phone thought it was still connected, but the car didn't. Unplugged and replugged the phone and all was well again.

Alan
 

·
Registered
Joined
·
91 Posts
Yesterday, my Sat Nav lost it's positioning 3 times. It seemed to think I was about 300 yards away from my real position. So another issue. It also lost Android Auto a couple of times on a long journey down to see my Dad, but not at all on the way back. But on the way down I had it resting on the wireless charger (the phone cannot wireless charge) but not on the way back. Could that make Android Auto do something weird that the head unit can't cope with?

My garage contacted me this morning and said they had seen the fuel reset issue a couple of times and that a new firmware update had cured it. So, maybe there's an 'engineers' firmware that we don't see - or maybe the latest update didn't install properly. In either case, I will let them do an update on the 12th May when it goes in - and report back on any progress (or not).

Alan
 

·
Registered
Joined
·
25 Posts
Strange but in my observation this behavior only started recently (6.1k miles/Blue). Let's just say it was well behaved since Oct 21. In April 22 (since re-fueling) has reset on two instances that I have observed. (Following this thread for a root cause/fix). Thanks.
 
1 - 19 of 19 Posts
Top