Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
525 Posts
Discussion Starter · #1 ·
I know this is a shot in the dark but has anyone ever had a rattle in the door? Just wondering if it was a "common" issue. I have a loud annoying rattling in the rear passenger door. Only happens at highway speeds but does it FOREVER going over 50mph. I took the door panel off and tightened every possible bolt, screw, etc. If anyone has had the door panel off you know that there is a large black plastic cover that has the speaker and window motor mounted to it. The noise is coming from behind that cover but I took all the bolts out but was unable to remove the cover. Not sure whats holding it on but that noise is behind it. Left the door panel off and had my wife drive while I rode in the back seat and pushed, pulled, and pried on the door but there was no change in sound. Whatever it is, is in the door behind that inner black cover. Had it back to the dealer twice and, of course, they say they can't replicate the sound. I told them they have to be going over 50mph and I am sure they just drove it down the street and back and never got to 50mph. I'm about to take a sledge hammer to this door.
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #3 ·
It sounds like a rattle not a tap but I will definitely check it as I am at wits end with it. I have a video of the noise on my phone but do not know how to post it.
 

·
Registered
Joined
·
525 Posts
Discussion Starter · #4 ·
You sure it's not this:

Needing some help with my wife’s new Santa Fe. - Hyundai Forums : Hyundai Forum

Had same issue until I looked nder the car for source of a rattle.

Sent from my SM-G930P using Tapatalk
In case someone has not told you today.....You are the f***in man!!!!!
It was the inner screw on that small flap in front of the rear tire. As soon as I touched it, it made the noise. I shoved it back into the hole. If it still makes the noise I will just take the screw and anchor out.
 

·
Registered
2014 SFS 2.4l
Joined
·
422 Posts
Haha, thanks and no problem. Drove me nuts for about 3 weeks. Not sure when/why those things get damaged. Maybe when people put the car on the lift and bump the rear mud guards. Anyway, enjoy.

Sent from my SM-G930P using Tapatalk
 
1 - 5 of 5 Posts
Top