Hyundai Forums banner

1 - 20 of 55 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Had this problem last winter. Took crank shaft sensor out checked rubber washer and only one their. Sprayed stater fluid in choke no start. Spinning over but wont fire. Car won't run in the cold help.
 

·
Registered
Joined
·
12,508 Posts
When it wont start is there spark at the plugs?
Is the fuel pump being switched on DURING CRANK?
There is usually a fuel pump test terminal on the engine bay fusebox specifically for testing that (F/PUMP CHK). The test terminal should be supplied with approx 10V while the engine is cranking.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Tried spraying starting fluid with no results. Engine sounds like no igniton. This gets me cause the only time it does this is when outside temp drops during winter.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #4
Fuel pump, coils, plugs, crank and cam sensor was replaced last winter after fuel pump went out. Turned cold outside and it wouldn't start all winter till spring. Ran no problems till now an early winter. Took cranksensor out incase of 2 o ring but looks okay. Do i need a block heater for this car or what. Drove last night fine. 20 degrees this morning and it wont start.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
Fuel pump went out and they put one in and it wouldn't start and said the cranksenor was bad. I replaced that and found they gave me a faulty fuel pump. Cold weather hit and i changed plugs and coils cause it wouldn't start. Still couldn't get it to start till the weather changed. Thought i had 2 o rings the crank sensor but it's not. Something stopping it from firing in cold weather.
 

·
Registered
Joined
·
3,983 Posts
Throwing parts at the engine trying to fix it??
My guess would be the cam sensor ... hahahaha

What tests were done to find out what is wrong with it?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #10
Jumped start this morning four extra juice. No start 14 degrees outside. Something shutting down ignition and fuel when its cold weather. Cranks over but won't fire. Only time this car don't start is winter.
 

·
Registered
Joined
·
12,508 Posts
You jumped it for extra juice and it still wouldn't start?
You say something is shutting down ignition and fuel. Have you actually confirmed that is the case or are you just assuming because it wont start?
 

·
Registered
Joined
·
45 Posts
Will it fire with the throttle cracked open a tad, could the IAC be failed shut?
Just thinking out loud here really.

Also worth checking if the immobiliser light is coming on.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #15
Some what assumming because it did this to me last winter. Used volt meter to check for fuel pump default. Sprayed quick start and open throttle. Turns over but no sound of trying to fire up. Pulled crankshaft sensor out and checked for extra o ring. Cold weather causes to expand and not send command to computer.Vehicle stopped running last winter. Did all kinds of tests that I could to get pump going. Coils, plugs, crank and cam sensor to get it going. The cold weathet hit and it wouldn't start all winter. Spring came it started until now winter back. Something about winter air kills this car.
 

·
Registered
Joined
·
12,508 Posts
Some what assumming
Your assumptions may be wrong, so take the time to check for spark, and check the fuel pump power supply (DURING CRANK) and report back what you find. We'll be in a better position to help once we know for sure what is going on.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #19
Your assumptions may be wrong, so take the time to check for spark, and check the fuel pump power supply (DURING CRANK) and report back what you find. We'll be in a better position to help once we know for sure what is going on.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #20
Assumption makes me look like a fool but temp got up to 31 degrees and I opened the choke and sprayed quick start and after a couple turns it started. Drove around and to a couple of stores. No problems cranks rite up. So theirs spark and fuel until the temp gets 20 degrees I'm assuming. I'm wait couple hours its getting late and the temp gonna drop and see if it starts. If if turn cold tonite it won't start in the morning. I'm leave a charge on battery to keep it up and warm slow charge. Now can anyone give me a suggestion on why this occurs when temp is cold.
 
1 - 20 of 55 Posts
Top