Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone. First time on the site so please forgive apparent ignorance!!

I have just bought a 2001 XG30 and, for the most part, I'm delighted with it. However, there are a few things I hope you guys can help with; namely:-

The engine warning light has come on. All the levels are fine and it drives well. Any suggestions?

When engaging drive from cold, there is a horrible "grinding" noise. This disappears as soon as in motion and it is not there when engaging when the engine is warm. Any ideas?

The driver's seat does not move back fully. All other adjustments are fine and it will move forward from its present position.

The window controls on the driver's door are not illuminated. I assume they are meant to?

That's it :) I hope you'll be able to offer some advice / guidance.

Many thanks.
 

·
Registered
Joined
·
47 Posts
The engine warning light has come on. All the levels are fine and it drives well. Any suggestions?

get your computer scanned and post the code on here ...could be anything

When engaging drive from cold, there is a horrible "grinding" noise. This disappears as soon as in motion and it is not there when engaging when the engine is warm. Any ideas?

no clue but sounds trans related

The driver's seat does not move back fully. All other adjustments are fine and it will move forward from its present position.

check under the seat and make sure there is nothing blocking the track...could also be a lose connector under the seat as well...you could remove the seat and diagnose more...my seat does not move up unless i wiggle the button just right

The window controls on the driver's door are not illuminated. I assume they are meant to?

mine have some that light up and some that do not...
 

·
senior member
Joined
·
22,788 Posts
:00000732: Welcome to the forum, Jenko!
 
1 - 4 of 4 Posts
Top