Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi

I’m new here at this forum. I have a XG-30 from 2002. Have to start to apologize if my English isn’t tat good but hope you understand anyway. I live in Sweden and don’t talk English that much.
My car has been running great until the past few days. The brake (the signal that light up when using the parking brake) and battery warning lights up sometimes and they stay for a whale then they start to flash or just stop shining. Sometimes I can be driving for an hour before it start and next time it takes not more than 30 seconds.
I also have some notice from the AC, can that be related?

I’m going to my brother’s wedding this weekend and need the car. It’s about 3,5 hour drive. Is it safe to use my XG-30 or should I use my Jetta instead?
 

·
Premium Member
Joined
·
15,116 Posts
welcome to the forums :00000732:

you must get your charging system checked out, its sounds like you may have a faulty alternator, do not take it for a long drive until you have got it checked out
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
My wife took the car to the city yesterday, even if I told her not to drive if the warning sign is on. She drove anyway and the car stop on her way back home, on the freeway. When I finally got the car back home I used my voltmeter to see what happens when the engine is running. I had 11,5 Volts on the battery when I started and after a few minutes it was down to 10.5 Volts so I guess a new alternator is needed to get the car running again.

Thanks for you help Montego.
 
1 - 3 of 3 Posts
Top