Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi!

First post here

Just bought à 2006 getz 1,4 with 125.000km on the clock

Few questions..

Ive changed sparkplugs, oil +filter and airfilter

1. The car starts easy when engine is cold and when Its warm.

Bur if i drive it like 1 km so Its not reached working temp and turn it of. Try to start it wont start easy. Need to give it some gas and it jumps on

Whats wrong?

2. Before i changed the sparks it heasitaded (spell?) when full throttle and engine light turned on. Havent happened after spark change.

3. Ratteling noise when the engine needs to work between 30-100% throttle. Nothing when i have 0-30% throttle


Ive just checked the obd and there where no faults.

I also checked the throttle position sensor with live data and when i hit the pedal to floor it only got up to 78% in computer.
Should it got to 100%?? Can the tps be adjusted?


Sorry if misspelled

Thanks
 

·
Registered
Joined
·
16 Posts
Bur if i drive it like 1 km so Its not reached working temp and turn it of. Try to start it wont start easy. Need to give it some gas and it jumps on
Hi,

I'm not sure if this will help you as I have the 1.3L engine (the 1.4L replaced the 1.3L) and as my issue is not exactly the same as yours.
Each time after I filled up the gas tank I have to give it some gas when I start the car or it will stall. It revs at about 500 rpm which seems not enough for the engine to keep running without stalling.
I don't know if this is normal at all (it's a second-hand car, and the first I own).

Also, could it be your battery ? When I first got mine, the battery was 8 years old, and it needed more than a couple of seconds to get the car started.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4 (Edited)
The battery is not oem it has been changed. Will test it at My work with à tester. But dont think Its the bat because it cranks easy but hard to start it if i dont give it some gas

Any ideas about the tps who shows 78% in computer when hitting pedal in the floor?

Ive calibrated some tps on motorcycles. You measure resistance between to connectorpins on the tps when engine is of. It can be adjusted so you get right ohm
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Seems normal after i searched the web.., strange

Number 1 and 2 in My problem list Seems to dissapered now. Starts fine and no engine light anymore

Only Nr 3 left, maybe camchain between the cams??
 
1 - 7 of 7 Posts
Top