Hyundai Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Bought a Hyundai i30 2011 MY on a 60 plate, car was supplied with wrong service book, that reflects the old service interval, the dealer says the new model is still coming through with the old style service book.
Spoke to Hyundai UK who told me to wait, but gave no date & to keep checking with the dealer.
More worringly, just recently when the engine is cold, I get into the car, turn the key to position 2, wait for glow plug indicator to go out then turn to position 3 to engage the staerter motor(accelerator not pressed). However, sometimes I get a cloud of blue smoke from the exhaust. Also, for the first 2 miles or so the engine runs rough, particularly at low revs.
Some times the smoke is so bad, its embarressing, and before you ask it is smoke and not steam, as the white smoke hangs around in the air for sometime.
Looking at the internet im not alone, but very frustrating for a car thats 3 weeks old with 1000 miles, more frustrating is alot of Kia owners, car has same engine, report dealer cannot fix this problem
Car been to dealer who experienced fault, but could not find a fault, car now in for 5 days.
http://www.youtube.com/watch?v=0Y4bsX0Wj_g
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Here we go, car ready for collection, Service Manager informs me, they are happy with the car, but a puff of white smoke is still produced, but they cannot find a problem & are happy to realease the vehicle.
It would appear my car has the known issue, which although nothing is broken & no fault found it produces some white smoke at startup.
We monitor over the next two days.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
--------------------------------------------------------------------------------

Ok my partner collected her car, and had a long conversation with the service manager, he confirmed this is a known problem, but no fault can be found, so no fix can be issued.
Dont buy a crdi engine.
 

·
Registered
Joined
·
425 Posts
From your video, I would say you do have a problem. You need to see another dealership for a second opinion, or at least contact another dealership and link to your video.


QUOTE (sootytorques @ Oct 13 2010, 03:49 PM) index.php?act=findpost&pid=363181
Dont buy a crdi engine.
That's harsh. Mine has 52,500 miles up and has never so much as puffed the slightest whiff of anything...
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Ok, car going back for one last attempt, have sent letter if not fixed, car will be rejected.
It would appear so many owners of CRDI engines put up with this problem, it should not smoke at all during startup.
 

·
Registered
Joined
·
15 Posts
I had a problem with my i30. It was finally attributed to a faulty drive plate wearing unevenly, resulting in the drive plate and clutch being replaced. Have you noticed any reduction in fuel consumption? Might be worth visiting the i30ownersclub.com forum and looking on other similar issues there and see if they can offer any help.

Rof
 
1 - 6 of 6 Posts
Top