Hyundai Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
A few weeks ago I bought a 2010 Elantra GLS w/the LG Navigation unit upgrade. When I connect my iPhone 4G to the unit via Bluetooth, a connection is made and then the entire system freezes up. I either have to pull the fuse and restart or turn the car off, turn bluetooth off on the phone, restart car and disconnect the phone. My phone has NO problems connecting to a 2 year old Pioneer unit in my old car I still have. Hyundai can not confirm whether it is the unit itself as they have no other on the lot to test with. They are placing all blame on Apple and state the unit is fine as other phones with connect. I questioned about a firmware update. They will talk to their engineers, etc... but basically told me, "Tough luck". Again, my phone works with older system. I have contacted Best Buy & Crutchfields to see if the iPhone is having bluetooth problems on any of their units and I'm told no.

Anyone out there with a similar issue or any advise?

Thanks.

UPDATE: If you only sync Phone Favorites & change Other Groups from All Contacts to None then I can get a clean connection with my favorites making me think this unit can't handle all of my contacts?? Still remaining a big issue that I've read on other car models, is that the sound quality is horrible. Ditto. I can hear everyone fine but they can't understand a word I say. Hyundai will not take ownership to quality of product despite many going to corporate level over this.
 

·
Registered
Joined
·
21 Posts
I don't know whether you'd see this thread again after a couple months, but I wanted to share my experience. I just got a 2010 Elantra SE with the navigation system and didn't have the problem you encountered when I connected my phone last night. One possibility I wanted to suggest was that it's possible that my iPhone 4 firmware is newer than what you had in August. I know that Apple addressed some Bluetooth issues in the 4.1 firmware, so perhaps the problem you're seeing is addressed by that firmware update.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi. Thanks for the comment but yes, the problem still exists & I even have a "new" iPhone 4 as the Apple store just replaced it for other issues. It has the most recent firmware, etc... Again, when I do the initial pairing the car & phone want to sync all contacts. I don't have that many but in either case I have to still turn the car off to unfreeze the system, switch the phone to favorites only and then turn the car back on. I only have to do this with the initial pairing and then it works in that mode going forward.

My other complaint is the microphone in the roof of the car. If I'm going down the freeway people say I sound like I'm in a tunnel. If I'm on a street rode going fairly slow, it's OK. A vibration issue? This should work regardless.....
 
1 - 3 of 3 Posts
Top