Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
HI ALL,
MY CAR, HYUNDAI GETZ 2008 DIESEL MODEL WON'T START. THE FIRST PROBLEM IS WHILE RUNNING THE VEHICLE SOMETIMES CHECK ENGINE LIGHT AND A COIL LOGO LIGHT JUST ON AND CAR WILL STRUCK. THEN IT WILL RUN SMOOTHLY FOR A SHORT TIME, THEN THIS WILL REPEAT.
AFTER SHOWING THIS TO MECHANIC THEY CHECKED THE DIESEL TANK, CLEANED IT AND REPLACED THE DIESEL FILTER ALSO. THEN CAR WON'T START NORMALLY, CAR STARTS BUT IT WILL GO OFF AFTER SOMETIME.
PLEASE HELP ME WITH THE SOLUTION,
WAITING FOR YOUR VALUABLE SUGGETIONS
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Did the mechanic check your starter?
YES, THEY CHECKED IT, THERE IS NO PROBLEM.
WHILE INSERTING THE KEY THERE IS NO IGNITION LIGHT AND ENGINE CHECK LIGHT ON DASH BOARD, SOMETIMES BOTH LIGHTS ARE BLINKING THREE TIMES.
IS THERE ANY PROBLEM WITH ECM/ECU...?
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,892 Posts
So there are no warning lights displayed when you switch the ignition on?
That wouldn't be a problem with the ECU. That will more likely be a power supply issue.

The first thing I would do with a fault like this is use a voltmeter to check the 12V power supply to the "CLUSTER" fuse, located on the dashboard fusebox. When the warning lights don't turn on when you switch the ignition on, probe the test terminals on top of the cluster fuse with the red voltmeter probe...see below. Check to see if there is 12V being supplied to the fuse when the ignition is switched on. The power for that fuse comes from the ignition switch. If you find there is no 12V supply to the fuse the ignition switch would be the prime suspect.
453425


If I helped you fix it, why not...

Your support is greatly appreciated
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
So there are no warning lights displayed when you switch the ignition on?
That wouldn't be a problem with the ECU. That will more likely be a power supply issue.

The first thing I would do with a fault like this is use a voltmeter to check the 12V power supply to the "CLUSTER" fuse, located on the dashboard fusebox. When the warning lights don't turn on when you switch the ignition on, probe the test terminals on top of the cluster fuse with the red voltmeter probe...see below. Check to see if there is 12V being supplied to the fuse when the ignition is switched on. The power for that fuse comes from the ignition switch. If you find there is no 12V supply to the fuse the ignition switch would be the prime suspect.
View attachment 453425

If I helped you fix it, why not...

Your support is greatly appreciated
Dear friend, Which fuse i need to check...? Could you please specify the fuse.
I will communicate with this solution to my mechanic,
Thanks for your Valuable Suggestion.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,892 Posts
Could you please specify the fuse.
I already did. It's the "CLUSTER" fuse, located on the dashboard fusebox.
That's the fuse that supplies power to the instrument cluster. If there are no warning lights displayed when the ignition is switched on the mechanic should check to see if there is 12V being supplied to that fuse. And while he's at it he should also check the ECU fuses. Those should have 12V when the ignition is switched on too.

If I helped you fix it, why not...

Your support is greatly appreciated
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I already did. It's the "CLUSTER" fuse, located on the dashboard fusebox.
That's the fuse that supplies power to the instrument cluster. If there are no warning lights displayed when the ignition is switched on the mechanic should check to see if there is 12V being supplied to that fuse. And while he's at it he should also check the ECU fuses. Those should have 12V when the ignition is switched on too.

If I helped you fix it, why not...

Your support is greatly appreciated
Good Morning,
I have checked and scanned the ECM, They told me that ECM is Not Responding, i need to replace the ECM,
what should i do next...?
Please Reply...
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,892 Posts
I have checked and scanned the ECM, They told me that ECM is Not Responding, i need to replace the ECM,
what should i do next...?
The ECU will not respond to the scan tool if it does not know the ignition is switched on. So what you should do is what I've already advised above. Check that there is power being supplied to the cluster and ECU fuses when the ignition is switched on. If the ignition switch is not supplying power to those fuses the engine ECU will not switch on, and will not be able to communicate with the scan tool.

If I helped you fix it, why not...

Your support is greatly appreciated
 
1 - 8 of 8 Posts
Top