Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi Folks joined this forum tonight.
I have a Matrix 53 plate. Been perfect until recently.
I seem to have a brake problem.
A few weeks ago upon starting the car and pulling away and then trying to apply the brakes, the brake pedal was solid and there was no braking effect. (Pretty Scary)
Turning the ignition off and then back on and waiting a few seconds it was back to normal.
This has happened several times.
The car has been to Hyundai and they said they cannot find a problem and unless it is happening at the time they cannot fix it.
The problem is happening still but very intermittently.
Is the car safe to use. It only happens on startup. Could this happen when I am driving?
Obviously a bit scared of using the car.
Anyone have any ideas of what this could be?
Many Thanks Folks :liebe011:
 

·
Registered
Joined
·
142 Posts
hi mr Moscosw !! and welcome to our forum ,

It seems to me as a Brake Booster failure , or may be the Vacum valve , sure nothing would be other than those two , have them checked very well before driving your car again , its unsafe to drive your car until you have the brake booster checked and repaired , or replaced .

thats my own opinion , hope other members give us more comments .

Best regards'
Ahmad_Abdallah
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
QUOTE (Ahmad_Abdallah @ Nov 3 2010, 02:24 PM) index.php?act=findpost&pid=368693
hi mr Moscosw !! and welcome to our forum ,

It seems to me as a Brake Booster failure , or may be the Vacum valve , sure nothing would be other than those two , have them checked very well before driving your car again , its unsafe to drive your car until you have the brake booster checked and repaired , or replaced .

thats my own opinion , hope other members give us more comments .

Best regards'
Ahmad_Abdallah
Thanks Pal.
Really pulling my hair out with this.
Not sure what to do with the car.
If I can't sort it guess i'll have to ebay it
 

·
Registered
Joined
·
142 Posts
QUOTE (moscow @ Nov 5 2010, 11:04 PM) index.php?act=findpost&pid=369304
You any Rough idea how much it will cost me to get these 2 parts replaced?
Many Thanks
sorry for being late , if its the vacum hose or valve then its not a big deal , but if it is the brake booster it costs here in egypt about 1000 EGP , thats about 200 american dollars , hope I was helpful , please keep us updated
 
1 - 6 of 6 Posts
Top