Hyundai Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
well I don't exactly know if that's what I should call it... I was driving last night around 10 and I pushed the gas down 3/4 of the way or so to pass around this car but instead of downshifting and accelerating, it just revved up all the way, i kept hitting the gas and it was like revving it in neutral then it kicked back into gear... should i be concerned? It was fine the rest of the night but I wasn't driving it hard.
 

·
Registered
Joined
·
108 Posts
Mine has done this, but only twice in over 70K miles. Both times I was going slightly uphill, and I nailed the accelerator just as the transmission was about the shift up to 3rd from 2nd. I've kept my transmission fluid clean with a drain/refill every 30K miles or sooner. The first time it happened was at around 20K miles, before the first drain/fill. The 2nd time was at around 60K miles, after a drain/fill using multi-vehicle ATF at around 58K miles. Happened with the original SP-III, and with multi-vehicle ATF, so it's not the fluid. I believe our transmission is just programmed in a way that it does not respond well to sudden quick inputs, probably depending on several factors (or a combination of factors) such as current transmission fluid temp, load, RPM, current gear, etc etc etc. Since it is a man-made machine, though, I don't expect mine to be flawless 100% of the time.

I wouldn't worry about it unless it happens frequently.
 
1 - 2 of 2 Posts
Top