Hyundai Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Hello, all. I'm reviving this old thread to find out if anyone else has experienced this problem and found a different solution. I've had this exact same steering problem intermittently for the past couple years.

I printed this forum post and took it to my local mechanic. The mechanic read it and said that sounds like it would be a reasonable fix for this problem. However, when he looked at my car, he found no sign of separation on the pulley and the belt was in good condition too. He ended up not replacing anything. He also said he followed all electrical components that are part of the steering system and didn't find anything that looked like it needed repair.

Before that, I left it at a Hyundai dealer for a week so they could drive it home and attempt to reproduce the problem. They had no luck doing so. They couldn't identify a problem either so their solution was to offer to replace the entire rack and pinion steering system.

Does anyone have any other suggestions? I'd love to get it fixed, but if I can't I'm going to have to dump the car to get something safer.
I had the exact same experience in wet weather in 2011 with respect to loss of steering, very scary and luckily no accident. I have my invoice from 2011 that indicates why I brought the vehicle into the dealership (Summit Hyundai,New Minas, NS) and in addition to the reason for the work order ( loss of steering in wet conditions) the invoice indicates that the mechanic " found crankshaft pulley is separating causing concern". (Quote from the invoice. ) Pulley was replaced and no problem until now, Dec 2015.....back to the garage again.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top