Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My scoosher appear to just be leaking as soon as I put water to in to clean my windscreens - I think something has come undone, a pipe or something. I anyone has experienced this, please advise.

It was working correctly up until a few days ago.

Thanks Sarah
 

·
MODERATOR
Joined
·
1,462 Posts
QUOTE (dyeke @ Nov 18 2010, 09:02 AM) index.php?act=findpost&pid=372700
My scoosher appear to just be leaking as soon as I put water to in to clean my windscreens - I think something has come undone, a pipe or something. I anyone has experienced this, please advise.

It was working correctly up until a few days ago.

Thanks Sarah

It all depends on "from where" it is leaking. Can you pinpoint the exact place?

If your Getz has rear window wiper and washer, it means your scoosher container has two motors and two outsides pipe lines coming out. Check if you can see the leaking coming from any point this two motors or pipes are attached. If so, you can check if there is a loose connection or missing clamp or something.

If you later discover that the leak is from a crack or hole in the container itself, you will have a bit of a problem, since this container is made from polyethilene plastic, to which almost nothing will stick to it.

Some years ago, I had a similar problem with another car and after testing about a dozen glues, epoxies and resins (to patch a crack in the container), I finally got it fixed with a strangle glue/resin called "Amazing Goop" (for outdoor and camping use).

Good luck and let us know what happened.

Robert B.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Robert,

My leak is from the front, I think it is from a leading pipe, possibly to the rear of the car. Looking down, it appears to be directly underneath the container but the fact that the car has such a low bumper it makes it really tricky to access.

Need to jack it up I think.

Cheers
 
1 - 3 of 3 Posts
Top