Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I have a Hyundai ix20 petrol 2018 and I do not know if this has been present since I had the car or just recently. But I feel/hear a bit of a knock/click which is faint, on the steering column plastic housing, just one click during a full turn of the steering wheel in very low speeds while braking and when dry steering when my feet is on the brake pad. You need to be quiet to hear it actually. It is not as loud as CV joint clunks or as continuous as it. I noticed that it occurs when it is cold as I had a run at the motorway and did not notice it happening after. It is also not present on normal speed after driving away from parking. So probably intermittent? And it only happens once on every full rotation of the steering wheel.

Also it is quite difficult to recreate as sometimes the noise is present sometimes it is not.

I doubt it is a CV joint problem as it does not click continuously and cannot be heard from outside. Nor does it click continuously when driving straight.

I also read this from the hyundai manual:

"When you operate the steering wheel in low temperatures, abnormal noise may occur. If the temperature rises, the noise will disappear. This is a normal condition."

So, might just be a case of "did not notice it before but noticed it now" so it is normal but I dont know? haha. Any input would be grand.

No problems with the wiper and light stalks, no horn problems, no airbag lights.

Would just like to know if this is a normal occurence and if you guys do experience it.

Sorry for the long post! Cheers guys.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
You don't know if this is a new sound? What?
Yeah I dont know if this sound was there when I bought the car last year as I always have the radio up hahaha. I just noticed it a few days/weeks ago as I turned the music off.

I had a drive earlier and the noise was definitely non existent. It appeared once though while backing up while parking at the supermarket but that was about 10-15 minutes after I had the car running, and the noise was very faint and it happened while I was steering from centre to right on full rotation. Then definitely non once home when I backed up to park.

I dont know if this is normal or just the cold. No judder, no bearing to the L or R while driving, no cv joint clunk, all electronics and airbags good. It's a puzzle really. I had a listen to the Elantra coupler problem videos on Youtube and the noise isnt that frequent nor that loud so I doubt it is that.
 
1 - 3 of 3 Posts
Top